Rockbox

Tasklist

FS#11650 - "Garbage sounds" on Musepack (.mpc)

Attached to Project: Rockbox
Opened by Leo Witt (some-xtc) - Saturday, 02 October 2010, 18:58 GMT
Last edited by Andree Buschmann (Buschel) - Saturday, 02 October 2010, 23:05 GMT
Task Type Bugs
Category Music playback
Status Closed
Assigned To No-one
Operating System All players
Severity Low
Priority Normal
Reported Version Daily build (which?)
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Hello again!

I've got another ( :-) ) complaint about Musepack:

On some tracks I hear annoying clink (It appears particularly after/with heavy basses).
This clink doesn't appear with other codecs on rockbox or with musepack+foobar2000.

I attached examples, where this clink very often appears.
I created these (of course) from my lossless source.
If you need a nother one, please let me know.

Tested with Clip+ & Fuze V1 & e260 v1

Greetings,
Leo
This task depends upon

Closed by  Andree Buschmann (Buschel)
Saturday, 02 October 2010, 23:05 GMT
Reason for closing:  Fixed
Additional comments about closing:  Fixed with r28200
Comment by Andree Buschmann (Buschel) - Saturday, 02 October 2010, 21:18 GMT
Two questions from my side:
Can you add an lossless compressed sample (e.g. flac)?
Can you give an exact timestamp where this sound is audible?

Edit:
Can you also add a sv7 encoded file?
-> The spectrum of the decoded sv8 file looks strange.
Comment by Leo Witt (some-xtc) - Saturday, 02 October 2010, 21:43 GMT
The sound is right at the beginning audible (after the first second it gets nasty)
Comment by Leo Witt (some-xtc) - Saturday, 02 October 2010, 21:46 GMT
here is the source-sample (splitted in two parts)
Comment by Andree Buschmann (Buschel) - Saturday, 02 October 2010, 22:23 GMT
Ok, found the change that introduced the failure (for both sv7 and sv8). I am searching for the root cause...
Comment by Leo Witt (some-xtc) - Saturday, 02 October 2010, 22:26 GMT
I have played a bit with the musepack-encoder parameters.
The clink is on q5 very pronounced and it gets quieter with each quality-level.
At q10 the clink is lost (or just inaudible).

Comment by Andree Buschmann (Buschel) - Saturday, 02 October 2010, 23:05 GMT
Fixed with r28200. The error was caused a copy-paste-error when introducing new macros (4 months ago!). Your tests verify this perfectly: When raising q-level fewer subbands will be zero'ed out (silenced). The error itself was errorous silencing of subbands -- old signal parts were kept instead. Therefor your experienced high frequency noise bursts after drums...

Thanks for supporting!!!!!

Loading...