Rockbox

Tasklist

FS#11654 - RockboxUtility 1.2.8 does not run in OS X Snow Leopard

Attached to Project: Rockbox
Opened by Stephen Drake (sduck) - Monday, 04 October 2010, 20:30 GMT
Last edited by Dominik Riebeling (bluebrother) - Tuesday, 05 October 2010, 19:56 GMT
Task Type Bugs
Category Rbutil
Status Closed
Assigned To No-one
Operating System All players
Severity Low
Priority Normal
Reported Version Rbutil 1.2.7
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Actually this is about RBUtil 1.2.8 - reported version doesn't have the current version listed yet.

Won't run on my machine - macbook (2007) running snow leopard 10.6.4.

Here are the first few lines of the crash report -


Process: RockboxUtility [4285]
Path: /Applications/RockboxUtility.app/Contents/MacOS/RockboxUtility
Identifier: com.rockbox.rbutil
Version: SVN $Revision: 28154 $ (1.2.8) (???)
Code Type: X86 (Native)
Parent Process: launchd [180]

Date/Time: 2010-10-04 15:28:08.383 -0500
OS Version: Mac OS X 10.6.4 (10F569)
Report Version: 6

Interval Since Last Report: 8736453 sec
Crashes Since Last Report: 70
Per-App Interval Since Last Report: 60 sec
Per-App Crashes Since Last Report: 11
Anonymous UUID: FC2C7E4C-D869-4064-9918-09903C6B5A05

Exception Type: EXC_BAD_ACCESS (SIGBUS)
Exception Codes: KERN_PROTECTION_FAILURE at 0x0000000000000000
Crashed Thread: 0 Dispatch queue: com.apple.main-thread

Thread 0 Crashed: Dispatch queue: com.apple.main-thread
0 com.apple.CoreFoundation 0x944dbb20 CFNumberGetValue + 128
1 com.rockbox.rbutil 0x000b8af3 System::systemProxy() + 115
2 com.rockbox.rbutil 0x000064cb RbUtilQt::proxy() + 411
3 com.rockbox.rbutil 0x0000a05b RbUtilQt::RbUtilQt(QWidget*) + 1307
4 com.rockbox.rbutil 0x00027ab2 main + 1186
5 com.rockbox.rbutil 0x00005e96 _start + 216
6 com.rockbox.rbutil 0x00005dbd start + 41

Thread 1: Dispatch queue: com.apple.libdispatch-manager
0 libSystem.B.dylib 0x987ed942 kevent + 10
1 libSystem.B.dylib 0x987ee05c _dispatch_mgr_invoke + 215
2 libSystem.B.dylib 0x987ed519 _dispatch_queue_invoke + 163
3 libSystem.B.dylib 0x987ed2be _dispatch_worker_thread2 + 240
4 libSystem.B.dylib 0x987ecd41 _pthread_wqthread + 390
5 libSystem.B.dylib 0x987ecb86 start_wqthread + 30

Thread 2:
0 libSystem.B.dylib 0x987ec9d2 __workq_kernreturn + 10
1 libSystem.B.dylib 0x987ecf68 _pthread_wqthread + 941
2 libSystem.B.dylib 0x987ecb86 start_wqthread + 30

Thread 0 crashed with X86 Thread State (32-bit):
eax: 0xa04a18cc ebx: 0x944dbab1 ecx: 0x00000000 edx: 0x00000016
edi: 0x00000000 esi: 0x00000000 ebp: 0xbffff598 esp: 0xbffff430
ss: 0x0000001f efl: 0x00010283 eip: 0x944dbb20 cs: 0x00000017
ds: 0x0000001f es: 0x0000001f fs: 0x00000000 gs: 0x00000037
cr2: 0x00000000
This task depends upon

Closed by  Dominik Riebeling (bluebrother)
Tuesday, 05 October 2010, 19:56 GMT
Reason for closing:  Fixed
Additional comments about closing:  The issue is caused by the proxy detection code. Fixed in svn. As a workaround you can enter arbitrary values in the proxy configuration (in "System Preferences.app") without enabling the proxy.
Comment by Dominik Riebeling (bluebrother) - Monday, 04 October 2010, 22:45 GMT
That's a bit strange -- Rockbox Utility is even built on a 10.6.4 machine. The crash report somewhat indicates that it's related to the proxy settings -- do you have anything set for system proxy?
Comment by Stephen Drake (sduck) - Tuesday, 05 October 2010, 00:20 GMT
Not that I know of. I don't even know what a system proxy is or how I would set one or unset it.
Comment by Stephen Drake (sduck) - Tuesday, 05 October 2010, 00:25 GMT
Just now I retried starting rockboxutility - for about the 100th time, with no hope of any change, but just wanted to make sure. This time, it started! But - I got this message - in the screen shot attached, about the system proxy settings being invalid. My fuze is out in the car, so i couldn't check and see if it works anyway, but will soon.
Comment by Stephen Drake (sduck) - Tuesday, 05 October 2010, 00:46 GMT
Ok, yes it works fine. At least for updating the rockbox software, and installing themes - I didn't try the bootloader install, didn't need to.

The only thing that I changed between the non-starts and the working start was a small widget added to the dashboard - proxy on/off http://download.cnet.com/Proxy-On-Off/3000-12565_4-82552.html - I did a quick google search on "os x system proxy" as I have no idea what it is, and found this little widget. I didn't actually change any of the settings that it controls - clicked the top one on and back off perhaps, but that's it. I don't know what it does.

Loading...