Rockbox

Tasklist

FS#11662 - my theme crashes player and the ui simulator.

Attached to Project: Rockbox
Opened by Teruaki Kawashima (teru) - Saturday, 09 October 2010, 09:50 GMT
Last edited by Jonathan Gordon (jdgordon) - Sunday, 10 October 2010, 06:48 GMT
Task Type Bugs
Category Themes
Status Closed
Assigned To No-one
Operating System Gigabeat F/X
Severity Low
Priority Normal
Reported Version Rbutil SVN
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

attached theme i made sometimes causes freeze on the player.
i tried it on the ui simulator and the simulator crashes.
i tried both on windows with http://rasher.dk/rockbox/simulator/ and on ubuntu 10.04 with I built and result is same.

the theme is for gigabeat f/x.
This task depends upon

Closed by  Jonathan Gordon (jdgordon)
Sunday, 10 October 2010, 06:48 GMT
Reason for closing:  Fixed
Additional comments about closing:  in r28226
Comment by Jonathan Gordon (jdgordon) - Sunday, 10 October 2010, 05:53 GMT
eek! That code is rather horrible.. although I can see why its done like that, volume bar looks pretty cool!
the problem is line 93, not sure why

Loading...