FS#11750 - Rockbox 3.7 Car adapter mode causes Fuze v2 to boot to Sandiskl firmware

Attached to Project: Rockbox
Opened by Brian (brian) - Thursday, 11 November 2010, 22:43 GMT
Last edited by MichaelGiacomelli (saratoga) - Friday, 12 November 2010, 00:58 GMT
Task Type Bugs
Category Settings
Status Closed
Assigned To No-one
Operating System Another
Severity Low
Priority Normal
Reported Version Daily build (which?)
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No


Player Type: Sansa Fuze v2
Reported Version: Release 3.7
I can't select the Fuze v2 or version 3.7 from the pulldown menus

Steps to reproduce the problem.

1. Enable "Car adapter mode"
2. Power off player using the power button.
3. Plug in the player to a 5v power source (12v car to 5v USB power adapter)
4. Car ignition on.

The player will boot into the original Sandisk firmware. I have not been able to test the power off functionality of car adapter mode because I can't even get Rockbox to load using the car adapter mode.

If I power on the player manually it still boots to Rockbox (not the Sandisk firmware).
This task depends upon

Closed by  MichaelGiacomelli (saratoga)
Friday, 12 November 2010, 00:58 GMT
Reason for closing:  Not a Bug
Additional comments about closing:  The fuzev2 is supposed to boot into the original firmware when you plug it in. This will not be changed until USB is working in rockbox. If you have further questions, take a look at the manual.
Comment by Dominik Riebeling (bluebrother) - Thursday, 11 November 2010, 22:46 GMT
This has nothing to do with car adapter mode, this is a bootloader thing. Please check if you're running the latest bootloader (I'm not sure if the Fuze bootloader defaults to loading the Sandisk firmware when booting with power connected)