Rockbox

Tasklist

FS#11775 - Playback stops and high pitch noise starts

Attached to Project: Rockbox
Opened by Gerry (lebowski) - Thursday, 25 November 2010, 03:59 GMT
Last edited by Andree Buschmann (Buschel) - Wednesday, 09 March 2011, 19:30 GMT
Task Type Bugs
Category Music playback
Status Closed
Assigned To No-one
Operating System iriver H10
Severity Low
Priority Normal
Reported Version Release 3.6
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Since upgrading to version 3.7, my iRiver H10 20gb sometimes stops playback of a given file, and emits a high pitched noise.
The remaining time is frozen at whatever point in the file it got stuck, and the only solution is to reboot.
I'm not able to navigate back out to select a different file.
At first I thought it was a corrupted file, but after rebooting the particular file playsback without issue.
This happens across a number of files, not any particular one.

This was not an issue in 3.6.
The Reported Version dropdown when creating this task doesn't allow me to choose 3.7 as the version which is why I reported it as 3.6 :-)
This task depends upon

Closed by  Andree Buschmann (Buschel)
Wednesday, 09 March 2011, 19:30 GMT
Reason for closing:  Fixed
Additional comments about closing:  This is assumed fixed with r29476. The change has been merged to v3.8 branch as well and might be part of a 3.8.x version.
Comment by menachem shapiro (menachem) - Sunday, 28 November 2010, 07:57 GMT
This sounds a lot like the same issue I reported here: http://www.rockbox.org/tracker/11764

I more commonly get get a freeze with no sound, but once in a while I will get a high pitched squeal (which I called static in my bug report).
Comment by Andree Buschmann (Buschel) - Sunday, 23 January 2011, 12:41 GMT
Please see  FS#11863  for a possible solution.
Comment by Dave Hooper (stripwax) - Thursday, 03 March 2011, 15:54 GMT
Try again with r29476 or newer

Loading...