Rockbox

Tasklist

FS#11777 - enhancement for rockbox_browse()

Attached to Project: Rockbox
Opened by Teruaki Kawashima (teru) - Saturday, 27 November 2010, 12:23 GMT
Last edited by Teruaki Kawashima (teru) - Wednesday, 15 December 2010, 13:03 GMT
Task Type Patches
Category User Interface
Status Closed
Assigned To No-one
Operating System All players
Severity Low
Priority Normal
Reported Version Daily build (which?)
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

This patch makes it easier to use rockbox_browse().
- add struct browse_context to be passed to rockbox_browse.
- show proper title when selecting e.g. .wps file or .sbs file from the settings menu.
- use rockbox_browse() to view playlist catalog (see also  FS#11678 ).

*Known issue
browser is messed up if rockbox_browse() is called recursively.
to reproduce:
highlight audio file or playlist in browser -> context menu -> Playlist Catalog -> View Catalog -> context menu -> Playlist Catalog -> Add to Playlist -> go back to browser.

future idea maight be to make rockbox_browse() available for generic purpose to select file.
e.g. use it to select file to save configure or playlist, to select .bmp file in rockpaint.
This task depends upon

Closed by  Teruaki Kawashima (teru)
Wednesday, 15 December 2010, 13:03 GMT
Reason for closing:  Accepted
Additional comments about closing:  committed in 28831 & 28836
Comment by Teruaki Kawashima (teru) - Sunday, 28 November 2010, 12:25 GMT
* separate playlist catalog stuff.
* add struct browse_context to struct tree_context so that it doesn't need to be passed through and possibly it can be used in other place (e.g. ft_load).
Comment by Teruaki Kawashima (teru) - Tuesday, 07 December 2010, 12:41 GMT
update patch.
* increase number of backups in rockbox_browse so that it can be called recursively bit more.
fixed issue described in the original post.
I set to 3 because currently max nest is 3.
* add callback_show_item member to customize what item will be shown in browser.
* removed BROWSE_ONEDIR as it doesn't seem to work well.
Comment by Teruaki Kawashima (teru) - Tuesday, 14 December 2010, 13:47 GMT
I commited browse.patch.

I'll commit browse-plcat.patch tomorrow.
Comment by Jonathan Gordon (jdgordon) - Tuesday, 14 December 2010, 20:53 GMT
please dont commit browse-plcat.patch, I'm doing the same thing in  FS#11808  and it will already have merge conflicts
Comment by Teruaki Kawashima (teru) - Wednesday, 15 December 2010, 04:07 GMT
imo, chaging playlist catalog to use rockbox_browse() should be a separate commit.
Comment by Teruaki Kawashima (teru) - Wednesday, 15 December 2010, 05:56 GMT
make playlist_catalog.c similar in the one in  FS#11808 , so there will be less conflicts.

Loading...