FS#11792 - Recursively Insert Directories Setting doesn't function

Attached to Project: Rockbox
Opened by Tobias Hahn (morowinger) - Sunday, 05 December 2010, 14:17 GMT
Last edited by Jonathan Gordon (jdgordon) - Tuesday, 07 December 2010, 09:44 GMT
Task Type Bugs
Category Playlists
Status Closed
Assigned To No-one
Operating System Another
Severity Low
Priority Normal
Reported Version Release 3.7.1
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No


I have a sansa clip+ player and the following bug occured to me:

whenever i want to listen to a single song from an artist, the whole directory is inserted into the playlist, no matter if the setting for this (recursively insert directories) is on off, on or 'ask".

it seems the default setting is 'on' and one can't change that with the setting. it does nothing.
This task depends upon

Closed by  Jonathan Gordon (jdgordon)
Tuesday, 07 December 2010, 09:44 GMT
Reason for closing:  Not a Bug
Additional comments about closing:  "recursive insert directories" adds all files in all directories under the current one. it does not control how files in the *current* directory are added. read the manual for the playlist insert options to do what you want
Comment by Nils Wallménius (nls) - Sunday, 05 December 2010, 22:34 GMT
recursively insert directories should only apply when you insert a dir into the playlist, so how are you inserting your song?