Rockbox

Tasklist

FS#11797 - database generation crash in 3.7.1, works ok in 3.7 (iPod Mini 1G)

Attached to Project: Rockbox
Opened by Mitch Meyran (MitchMeyran) - Tuesday, 07 December 2010, 23:47 GMT
Last edited by Andree Buschmann (Buschel) - Sunday, 23 January 2011, 12:36 GMT
Task Type Bugs
Category Database
Status Closed
Assigned To No-one
Operating System iPod Mini
Severity Low
Priority Normal
Reported Version Release 3.7.1
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

on a rockboxed iPod Mini 1st gen. using a CF card as replacement for the HDD, every time I try to generate the database with 3.7.1, I get a data abort when rebooting.
The card was reformatted and checked for errors, and checked out perfectly thrice.
Deleting .rockbox, then installing original 3.7, the database creation goes off without a hitch.

Looks like a regression to me.
This task depends upon

Closed by  Andree Buschmann (Buschel)
Sunday, 23 January 2011, 12:36 GMT
Reason for closing:  Fixed
Additional comments about closing:  Fixed with r29081.
Comment by MichaelGiacomelli (saratoga) - Wednesday, 08 December 2010, 14:56 GMT
3.7.1 only adds a few commits to 3.7, so it should be easy enough to figure out which one causes the problem for you. My guess would be r28652 though, since thats the only one that even touches the database.
Comment by sideral (sideral) - Wednesday, 08 December 2010, 15:39 GMT
r28652 would be the change in  FS#11722 . The code only runs if runtime statistics are enabled, so disabling that would be an easy first check.

Loading...