Rockbox

Tasklist

FS#11812 - Clip+ non zero output when paused

Attached to Project: Rockbox
Opened by James Duley (jdc) - Thursday, 16 December 2010, 08:35 GMT
Last edited by Bertrik Sikken (bertrik) - Saturday, 17 March 2012, 23:37 GMT
Task Type Bugs
Category Music playback
Status Closed
Assigned To No-one
Operating System Sansa AMSv2
Severity Low
Priority Normal
Reported Version Release 3.7.1
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

By measuring with a multimeter I found that when paused the clip+ outputs a constant DC voltage that will change with the volume. I believe it just outputs the sample it was on when it is paused rather than zero. It changes every time I pause it and is postive and negative. When I tried a file with just silence it was always zero when paused. The OF does not have this problem. This has a real potential to damage headphones if you have the volume up and were unlucky enough to pause on a peak.

Brief discussion on Head-Fi http://www.head-fi.org/forum/thread/528329/clip-dc-offset#post_7127751
This task depends upon

Closed by  Bertrik Sikken (bertrik)
Saturday, 17 March 2012, 23:37 GMT
Reason for closing:  Fixed
Additional comments about closing:  Appears to be fixed now
Comment by MichaelGiacomelli (saratoga) - Thursday, 16 December 2010, 15:21 GMT
We probably never noticed this because fade to pause is on by default in rockbox, and that should zero the output.
Comment by James Duley (jdc) - Thursday, 16 December 2010, 21:06 GMT
Thanks saratoga, never thought about that but I just checked and I don't have it on. I just tested it and it doesn't make a difference either way but I did find I get a squeak at pause and unpause with fade on but not with it off
Comment by James Duley (jdc) - Thursday, 16 December 2010, 21:06 GMT
I mean I do/did have it on.
Comment by Jim McAtee (jmcatee) - Sunday, 19 December 2010, 23:38 GMT
I hear this too on my Fuze v2 with 3.7.1. When Fade on Stop/Pause is disabled the noise disappears.
Comment by sideral (sideral) - Friday, 18 February 2011, 10:21 GMT
Several people have noticed audible clicks on AMSv2 platforms when changing the volume while playback is paused. Perhaps these observations are an artifact of the present issue (nonzero voltage while paused)?

jdc, Could you please check whether the voltage you've been measuring changes when the volume is changed during pause?
Comment by James Duley (jdc) - Sunday, 06 March 2011, 21:25 GMT
Hi, sideral. yes it does
Comment by James Duley (jdc) - Sunday, 06 March 2011, 21:37 GMT
Comment by MichaelGiacomelli (saratoga) - Monday, 25 July 2011, 02:24 GMT
I took some measurements with the current build, and the DC level on pause or stop did not seem to be related to last sample on my Clip+ with current SVN. Instead, I got a small noise-like waveform that was related to the volume in amplitude (but only about 30mV at +6dB) but completely random as a function of time. After 2 seconds I could see a small pop as the DAC switched off. At that point the level dropped to within a few mV of 0 (the exact level also depended on volume).

Using high efficiency IEMs at +6dB I could confirm that my scope readings matched what happened with headphones: I hear a deafening music, then a faint hiss, then a pop as the output turns off. Finally I hear only a very faint hum which I assume is cross talk from the player's CPU.

Edit: I should mention I made these measurements using a 1 megaOhm input impedance scope.
Comment by Michael Sevakis (MikeS) - Monday, 25 July 2011, 05:51 GMT
PCM doesn't really immediately stop on pause of the playback engine , but plays 3 seconds of silence after the last activity from some source before actually stopping it.
Comment by MichaelGiacomelli (saratoga) - Saturday, 03 March 2012, 20:16 GMT
Since I can't reproduce this, I think its fixed.

Loading...