Rockbox

Tasklist

FS#11820 - iPod Colour LCD: artefacts left onscreen at shutdown.

Attached to Project: Rockbox
Opened by Hayden Pearce (St.) - Tuesday, 21 December 2010, 08:42 GMT
Last edited by Andree Buschmann (Buschel) - Wednesday, 12 January 2011, 07:36 GMT
Task Type Bugs
Category LCD
Status Closed
Assigned To Andree Buschmann (Buschel)
Operating System iPod 4G Color
Severity Low
Priority Normal
Reported Version Daily build (which?)
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

r28861

iPod Colour shows horrible artefacts left on the screen for quite some time after shut-down.
More often than not in the form of a pair of jagged vertical lines in the approximate centre of the screen, spaced 1~2px apart.
Looking rather similar to a lightning strike.
Very occasionally (1 in 50 or so) a piece of the theme or statusbar is "left behind" in the same or similar way on shut-down and fades out very slowly over a period of minutes.
It happens on both manual and idle time-out shut-down, but seems to present more reliably when the device is shut-down manually.
This is present for me on two different devices (iPod Colour 64GB CF and iPod Colour 60GB HDD)
I have also tried the 3.7 and 3.7.1 release builds and the problem is present there also.
[St.]
This task depends upon

Closed by  Andree Buschmann (Buschel)
Wednesday, 12 January 2011, 07:36 GMT
Reason for closing:  Fixed
Additional comments about closing:  Fixed with r29033
Comment by Andree Buschmann (Buschel) - Sunday, 09 January 2011, 17:39 GMT
This patch takes the lcd_type identification and shutdown code from FS#10034.
Comment by Andree Buschmann (Buschel) - Sunday, 09 January 2011, 19:51 GMT
Positively tested on iPod color (lcd_type 3) by Hayden Pearce.
Comment by Andree Buschmann (Buschel) - Monday, 10 January 2011, 22:11 GMT
v04 fixes white flashes of the display when entering sleep mode or when shutting down.

Positively tested on iPod color (lcd_type 3) and nano1g (lcd_type 1) by Hayden Pearce. No lcd_type 2 available for testing yet.

Loading...