Rockbox

Tasklist

FS#11823 - AMSv1 *PANIC* microSD init failed :-2 since r28834

Attached to Project: Rockbox
Opened by Rose Tattoo (rosetattoo) - Tuesday, 21 December 2010, 15:24 GMT
Last edited by Michael Chicoine (mc2739) - Wednesday, 29 December 2010, 22:23 GMT
Task Type Bugs
Category Drivers
Status Closed
Assigned To No-one
Operating System Another
Severity Low
Priority Normal
Reported Version Daily build (which?)
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Hello,

I have a problem on Sansa e260v2. After I installed r28873 the microSD is not seen in file browser. When I insert the microSD after the start of rockbox i get the error "microSD init failed :-2".

When I start the sansa firmware the microSD works normal. I can't say if this is the first build that have this problem, because the last update of my sansa player is a few weeks ago.

Thanks for help.

Horst
This task depends upon

Closed by  Michael Chicoine (mc2739)
Wednesday, 29 December 2010, 22:23 GMT
Reason for closing:  Fixed
Additional comments about closing:  This should be fixed with r28925.
Comment by Michael Chicoine (mc2739) - Wednesday, 22 December 2010, 15:12 GMT
I have confirmed this problem on my e260v2. I get:

*PANIC*
microSD init failed : -2

when inserting the microSD card after boot. If I insert the microSD card before boot, it does not panic, but the microSD is not detected.

This started with the r28834 commit which modified CPU and peripheral clocks to improve battery life.

Comment by Michael Chicoine (mc2739) - Wednesday, 22 December 2010, 15:22 GMT
Edited task name with better description and changed Player Type to "Another" since e200v2 is not available.
Comment by Martin (positrons) - Sunday, 26 December 2010, 08:14 GMT
I had the same problem with a Sansa c250 v2 using r28901, but when I reverted to r27994 (because I had it) the problem went away.

Loading...