Rockbox

Tasklist

FS#11829 - %tx tag causes sim segfault

Attached to Project: Rockbox
Opened by Marcin Bukat (MarcinBukat) - Thursday, 23 December 2010, 22:20 GMT
Last edited by Jonathan Gordon (jdgordon) - Friday, 24 December 2010, 08:03 GMT
Task Type Bugs
Category Themes
Status Closed
Assigned To No-one
Operating System All players
Severity Low
Priority Normal
Reported Version Release 3.7.1
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Here are two simple .fms attached which use %tx tag as conditional. One crashes sim the second works just fine.
This task depends upon

Closed by  Jonathan Gordon (jdgordon)
Friday, 24 December 2010, 08:03 GMT
Reason for closing:  Fixed
Additional comments about closing:  r28890 is the quick fix... i intend on fixing it properly during the week
Comment by Jonathan Gordon (jdgordon) - Friday, 24 December 2010, 04:10 GMT
bugger. I'm confident I know where the problem is but not why. Its in the special HAVE_FOO handling for the parser so it can skip over tags which available on non-FOO targets.

I actually need to know which target you are buidling for (I assume mpio?) %?tx<%Vd(rds_present)> [should] become[s] %?tx<|> when tx is false which should be handled fine, but I'll check this... going on a flight now so hopefully I'l have a fix by the time we land :p


edit: ah crash is in the renderer not parser.... hopefully its still a parser error though, I'll hopfully have a fix for this soon

Loading...