Rockbox

Tasklist

FS#11851 - clip+: sound messes up (popping) with certain songs

Attached to Project: Rockbox
Opened by clumsy moe (clumsymoe) - Friday, 31 December 2010, 08:15 GMT
Last edited by MichaelGiacomelli (saratoga) - Wednesday, 08 February 2012, 20:33 GMT
Task Type Bugs
Category Drivers
Status Closed
Assigned To No-one
Operating System Sansa AMSv2
Severity Low
Priority Normal
Reported Version Release 3.7.1
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Strange audio playback problems on clip+ with particular files. Attached is a 1 min ish clip of one of the songs that was causing this problem, the other songs that have this problem are about the same (loudly mastered EDM). The problem only occurs in this song during the chorus, the other parts of the song use a different kick/bassline and the problem doesn't exist there.

From my testing it occurs regardless of volume. It happened to me with no sound modifiers on, flat EQ and everything off. Didn't try messing with them. Doesn't happen on my X5L with 3.6 or on the clip with default firmware.
This task depends upon

Closed by  MichaelGiacomelli (saratoga)
Wednesday, 08 February 2012, 20:33 GMT
Reason for closing:  Out of Date
Additional comments about closing:  Lots of fixes have gone in for playback and the dac driver since this was last tested. No one has confirmed that it still exists after 8 months. If someone can reproduce this, ask in IRC to have it reopened.
Comment by MichaelGiacomelli (saratoga) - Friday, 31 December 2010, 08:30 GMT
I listened 5 times through on the Clip+ without any issues. You mentioned a chorus, but this track is an instrumental. Any chance you uploaded the wrong file? If not, its probably just something specific to your player.
Comment by clumsy moe (clumsymoe) - Friday, 31 December 2010, 16:51 GMT
Well the chorus of the song, I guess. After clipping out this section of the song I put it on the clip to make sure it still caused problems. It's defiantly the correct song.

Here's a recording of playing the file in rockbox, then switching to the default firmware and playing it (I was a bit slow to match the volume on the default firmware).

http://www.mediafire.com/?gbzfafa1ambyhm2
Comment by Andree Buschmann (Buschel) - Saturday, 08 January 2011, 16:51 GMT
The file output is clipped. Did you try to use Replaygain?
An easy test would be to set Rockbox Replaygain (Menu/Playback Settings/Replaygain) to on and use a pre-amplification of -1 dB.
Comment by Andree Buschmann (Buschel) - Sunday, 23 January 2011, 11:53 GMT
Another user reported this for the clip+ as well. The user also reported that playback of a wav-file that was decoded on a PC showed the same behaviour. Maybe something misconfigured in the codec's signal path?

Link to the thread: http://forums.rockbox.org/index.php/topic,27066.0.html

Edit: The popping noise is very prominent in the files that are linked in the forum thread. The noise does not seem to be connected to the amplitude or any clipping. It sounds like discontinous wave form (missing or doubled samples) in the audiostream. Maybe something related to pcm buffer / DMA transfer?
Comment by MichaelGiacomelli (saratoga) - Monday, 25 July 2011, 04:06 GMT
Does this still occur after the AGC fix went in today?
Comment by MichaelGiacomelli (saratoga) - Friday, 20 January 2012, 20:44 GMT
Anyone still have this issue? If not, I'm going to close it.
Comment by clumsy moe (clumsymoe) - Friday, 20 January 2012, 20:46 GMT
I haven't listened to that song in a while, was that fix included in the latest version of rockbox? If so I can put that on my clip and test it sometime this weekend.

I'm not sure who put popping in the title, it's defiantly not popping.
Comment by Michael Sevakis (MikeS) - Friday, 20 January 2012, 21:49 GMT
Andree Buschmann changed the task title on 23 Jan.

ETA: 2011, that is.

Loading...