Rockbox

Tasklist

FS#11973 - ipod nano 1G loses sound after record mode is turned on and off

Attached to Project: Rockbox
Opened by Martins (msh) - Monday, 28 February 2011, 19:31 GMT
Last edited by Andree Buschmann (Buschel) - Thursday, 03 March 2011, 20:54 GMT
Task Type Bugs
Category Music playback
Status Closed
Assigned To No-one
Operating System iPod Nano
Severity Low
Priority Normal
Reported Version Release 3.8
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

After record mode is turned on and off on nano 1G 3.8, afterwards there is no sound, unless player is turned off and on. A person @ IRC notified me that after 3.7 version had been made some change for nano's recording mode, so I tried 3.7 - no problems, several times turned recording mode on, off and resumed playback and no sound loss.
This task depends upon

Closed by  Andree Buschmann (Buschel)
Thursday, 03 March 2011, 20:54 GMT
Reason for closing:  Fixed
Additional comments about closing:  Fixed with r29513, thanks to Martins for testing!
Comment by Andree Buschmann (Buschel) - Monday, 28 February 2011, 19:38 GMT
I suspect r28341 to be the cause. This change implemented audiohw_set_monitor(bool) for WM8975.
Comment by Andree Buschmann (Buschel) - Monday, 28 February 2011, 21:54 GMT
The failure seems to be caused by unbuffered writes to the WM8975 registers during initialization. The new implementation of audiohw_set_monitor() uses these buffers. In consequence the first call of audiohw_set_monitor() will disable the connection from DAC to mixer until the next restart.
Comment by Andree Buschmann (Buschel) - Thursday, 03 March 2011, 20:51 GMT
New version v02 of the patch.
- replace all wmcodec_write() with wm8975_write()
- remove unused code (#ifdef-related)
- add explicit register buffer size and check for out-of-bounds

Loading...