Rockbox

Tasklist

FS#11976 - database-related (?) data aborts with 3.8

Attached to Project: Rockbox
Opened by Dave Hooper (stripwax) - Tuesday, 01 March 2011, 00:25 GMT
Last edited by sideral (sideral) - Wednesday, 02 March 2011, 07:24 GMT
Task Type Bugs
Category Database
Status Closed
Assigned To No-one
Operating System iPod 5G
Severity High
Priority Normal
Reported Version Release 3.8
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

With an install of 3.8, when I initialise database from the menu, all seems to be ok. However, when I enable Auto Update=Yes, I get a data abort (around address 0004exxx , didn't keep a note of the address) shortly after rebooting. On subsquent reboot, I reproducibly get a data abort during the Committing Database 4/9 step.

Following irc conversation, I'm posting metadata logs. the referenced file is too large to attach here by I can forward it to you if you think it is relevant.

I can also post the actual database files from rockbox (the ones that appear to reproducibly data abort at 4/9), as I backed these up before deleting them. Needed to delete them so I could use rockbox again.
This task depends upon

Closed by  sideral (sideral)
Wednesday, 02 March 2011, 07:24 GMT
Reason for closing:  Out of Date
Additional comments about closing:  Apparently unrelated to the database. The metadata log suggested random data corruption (corrupted file paths), which may be why disabling ATA DMA (r29476) may have fixed the problem.
Comment by Dave Hooper (stripwax) - Tuesday, 01 March 2011, 23:14 GMT
Reproduced example. new metadata log attached. Operation was: enable database Auto Update=Yes. Turn off. Turn back on & quickly go to system->debug->metadata log to enable it. I even left it on that menu - I don't have auto playback resume on poweron so no audio buffering should have been taking place.

At a guess, the metadata.log appends (I didn't delete any existing metadata log when doing the previous testing). i made sure i deleted metadata.log prior to this test.
Comment by Dave Hooper (stripwax) - Wednesday, 02 March 2011, 00:05 GMT
At sideral's advice in irc , I tried a recent svn build incorporating r29476. i have not been able to reproduce the Data Abort since then..

Loading...