Rockbox

Tasklist

FS#12053 - database.ignore files do not stop database scanning directories

Attached to Project: Rockbox
Opened by Iain Cheyne (icheyne) - Thursday, 07 April 2011, 21:09 GMT
Last edited by Frank Gevaerts (fg) - Friday, 08 April 2011, 11:21 GMT
Task Type Bugs
Category Database
Status Closed
Assigned To No-one
Operating System Sansa AMSv2
Severity Low
Priority Normal
Reported Version Daily build (which?)
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

r29690

In the manual it says that you can use database.ignore files to stop the database scanning certain directories and all the subdirectories beneath.

http://download.rockbox.org/daily/manual/rockbox-sansaclipplus/rockbox-buildch4.html#x7-450004.2.2

Unfortunately this does not work, and some files are being scanned into the database.

There are no database.unignore files on my device.

Does it make a difference if the database.ignore file and directory are on a SD card?
This task depends upon

Closed by  Frank Gevaerts (fg)
Friday, 08 April 2011, 11:21 GMT
Reason for closing:  Not a Bug
Additional comments about closing:  user error
Comment by MichaelGiacomelli (saratoga) - Thursday, 07 April 2011, 23:30 GMT
Can you suggest a way to reproduce the problem?
Comment by Iain Cheyne (icheyne) - Friday, 08 April 2011, 09:13 GMT
It is a shame I cannot change the original bug.

1. Add an empty text file named database.ignore to a directory containing subdirectories containing audio files.
2. Go to the Database menu
3. Press Initialize Now
4. Wait for the database to be regenerated.
5. See if you can find the audio files in the ignored directory and any sub-directories in the database.
Comment by Frank Gevaerts (fg) - Friday, 08 April 2011, 09:17 GMT
Did you verify that the tracks you find aren't somehow from a different copy, such as .trash or similar?
Comment by Iain Cheyne (icheyne) - Friday, 08 April 2011, 10:30 GMT
:-s

This one was a stupid user error. I had somehow copied the folder I wanted to ignore into another directory on the player.

Major apologies.

Loading...