Rockbox

Tasklist

FS#12087 - SPC files ignore Album Artist tag

Attached to Project: Rockbox
Opened by Benjamin Samuel (Dodecahedron) - Saturday, 30 April 2011, 00:40 GMT
Last edited by Andree Buschmann (Buschel) - Tuesday, 17 May 2011, 21:05 GMT
Task Type Bugs
Category ID3 / meta data
Status Closed
Assigned To No-one
Operating System All players
Severity Low
Priority Normal
Reported Version Release 3.8.1
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

In "Database > Album Artist", the Artist tag gets read instead.

Happens on Sansa Clip+
This task depends upon

Closed by  Andree Buschmann (Buschel)
Tuesday, 17 May 2011, 21:05 GMT
Reason for closing:  Not a Bug
Additional comments about closing:  SPC does not offer an album artist tag. rockbox does not support or plan to support a generic metadata tag like APE or ID3 for SPC-files.
Comment by Bertrik Sikken (bertrik) - Saturday, 30 April 2011, 09:06 GMT
Have you looked at the specification of the SPC format? (see for example http://en.wikipedia.org/wiki/SPC700_sound_format )
As far as I understand, the metadata for an SPC file does not contain an album artist tag.
Comment by Benjamin Samuel (Dodecahedron) - Saturday, 30 April 2011, 13:50 GMT
Is that so? Under FB2K the tag type is shown as apev2 and Album Artist is honoured. Although this program could be using some kind of workaround.
Comment by Andree Buschmann (Buschel) - Saturday, 30 April 2011, 17:15 GMT
rockbox seeks for the spc specific "ID666"-tag and does not search for ID3- or APE-tags. This could of course be implemented, but I am not sure it is wanted...
Comment by MichaelGiacomelli (saratoga) - Saturday, 30 April 2011, 21:28 GMT
Does anything even read APEv2 tags on SPC files besides foobar? foobar will add APEv2 tags to just about anything, but that doesn't mean other things will understand them.

Loading...