Rockbox

Tasklist

FS#12089 - New Rockbox Utility is inaccessible with NVDA

Attached to Project: Rockbox
Opened by Kevan (KevanGC) - Sunday, 01 May 2011, 06:30 GMT
Last edited by Dominik Riebeling (bluebrother) - Monday, 09 May 2011, 17:38 GMT
Task Type Bugs
Category Rbutil
Status Closed
Assigned To No-one
Operating System All players
Severity Low
Priority Normal
Reported Version Release 3.8.1
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Hi,

I downloaded Rockbox 3.7.1 with the utility in December and it worked fine. I am blind, so I use NVDA, a screen-reader for Windows. I have Windows 7 64 Bit. The utility was very useable with NVDA in 2010.

I just tried Rockbox 3.8.1, but the utility is now very inaccessible. I could probably upgrade, but I don't want to run the risk of breaking my MP3 player.

Did you change the utility in any way since December? I still have the old utility, and I plan to keep it until the new one's accessible.

Thanks,
Kevan
This task depends upon

Closed by  Dominik Riebeling (bluebrother)
Monday, 09 May 2011, 17:38 GMT
Reason for closing:  Fixed
Additional comments about closing:  This is a build setup issue. Rockbox Utility 1.2.10 has been built using a different setup that doesn't show this problem.
Comment by Kevan (KevanGC) - Sunday, 01 May 2011, 06:37 GMT
By the way, the old Utility I got in december is version 1.2.8. The new inaccessible one is 1.2.9.
Comment by Dominik Riebeling (bluebrother) - Sunday, 01 May 2011, 07:55 GMT
As you can see from the Rockbox Utility page in the wiki a new release was just made yesterday -- 1.2.9. So yes, it has been changed. It needs to get changed to fix bugs ... Anyway, it's possible that the problem is caused due to the fact that 1.2.9 has been built with a different setup and that setup misses the accessibility plugin for Qt. I'll check that later today.

Loading...