Rockbox

Tasklist

FS#12128 - Allow selecting multiple entries in playlists

Attached to Project: Rockbox
Opened by Stephan Grossklass (keyb_gr) - Wednesday, 25 May 2011, 13:23 GMT
Last edited by Jonathan Gordon (jdgordon) - Wednesday, 25 May 2011, 13:26 GMT
Task Type Patches
Category Playlists
Status Closed
Assigned To No-one
Operating System All players
Severity Low
Priority Normal
Reported Version Daily build (which?)
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

The aim of this task is coming up with a patch that allows selecting multiple entries at once in a playlist, e.g. for moving or copying them. At present, handling of these operations in playlist viewer is strictly single-entry oriented.

Following a top-down approach, the first step is coming up with a sensible UI implementation (spec) that is efficient yet does not break on any devices. Two versions of this are attached (terminology is not too far off I hope), along with first notes on things internal.

Needs discussion.

(I have no idea which kinds of buttons we have available on all targets, and I am neither very familiar with playlist_viewer.c nor have I ever written such a selection thingy.)
This task depends upon

Closed by  Jonathan Gordon (jdgordon)
Wednesday, 25 May 2011, 13:26 GMT
Reason for closing:  Not a Bug
Additional comments about closing:  When you have a patch you can open a task up, discussion belongs int he forum and irc

Loading...