Rockbox

Tasklist

FS#12213 - Cabbie v2 for 128x64x1 (sansa clips): show volume in dB when changing volume

Attached to Project: Rockbox
Opened by Bertrik Sikken (bertrik) - Sunday, 31 July 2011, 08:29 GMT
Last edited by Bertrik Sikken (bertrik) - Tuesday, 21 February 2012, 09:06 GMT
Task Type Patches
Category Themes
Status Closed
Assigned To No-one
Operating System Sansa AMSv1
Severity Low
Priority Normal
Reported Version Release 3.8.1
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

This patch shows the volume numerically in dB for about 1 second when changing volume.

This behaviour was in the clip wps before it was merged with the wps from the iriver remote. I liked it very much, so this patch brings it back.
This task depends upon

Closed by  Bertrik Sikken (bertrik)
Tuesday, 21 February 2012, 09:06 GMT
Reason for closing:  Out of Date
Additional comments about closing:  Needs to be coordinated with all cabbiev2 wps'es, will probably never happen.
Comment by Thomas Martitz (kugel.) - Sunday, 31 July 2011, 09:42 GMT
We complained when it was introduced the first time that it was only introduced for the clip wps, and not for the others. We should do better this time.
Comment by Bertrik Sikken (bertrik) - Sunday, 31 July 2011, 11:09 GMT
The history of this feature is a bit more complicated than I initially thought.

Initially the clip wps was copied from the irivier remote 128x64x1 wps and modified specifically for the clip to avoid any viewport crossing the yellow/cyan boundary (which looks very ugly). Later, during devcon 2010, this clip-specific wps was merged back into the generic 128x64x1 WPS. During this merge, it also lost the "show numerical volume" feature, that was apparently present in the wps that the clip-specific wps was originally based on.

I didn't realise until now that this feature is not present in any other cabbiev2 wps for different targets.

I still think this is a very useful feature, I often find myself switching back to the list view, just to see the exact volume level.
Comment by Paul Louden (Llorean) - Sunday, 31 July 2011, 14:46 GMT
I think that it would serve best to include the feature in all CabbieV2 variants. I frequently find myself toggling the menu just to check the actual volume number, especially on my Clip+ but also on other targets.
Comment by Jonathan Gordon (jdgordon) - Sunday, 31 July 2011, 23:24 GMT
Then do the work yourself?
Comment by Stephen Carroll (StephenCarroll) - Wednesday, 03 August 2011, 15:39 GMT
I was going to upload them individually but there's loads so I zipped them all up.
I've basically copied the %mv line instead of the %pv line.
I can't use patch so maybe someone could create a patch based on these files ?
I've tested most of them and seems to work as advertised.
Comment by Thomas Martitz (kugel.) - Wednesday, 03 August 2011, 15:51 GMT
Why not provide a patch against SVN?
Comment by Bertrik Sikken (bertrik) - Wednesday, 03 August 2011, 17:15 GMT
I experimented with how numeric volume looks on a colour target (the e200) with cabbiev2.

The default white colour of the numeric volume looks quite "off" compared with the rest of the (mostly yellow) cabbiev2 theme. So use yellow for this too?
Also, I think we should center the numeric volume in the space currently occupied by the volume bitmap. Horizontal is easy, just use %ac (align centre). To align vertically, we might need to define a new centered viewport with the numeric volume, and switch with %?mv<Vd(x)|Vd(y)> between numeric and bitmap.
Comment by Stephen Carroll (StephenCarroll) - Wednesday, 03 August 2011, 19:25 GMT
Most of the other text i.e. artist,album title are in white tho, so wouldn't it lok weird having it in yellow and the rest in white ?

Kugel, I didn't provide a patch because I don't know how.
Comment by Hayden Pearce (St.) - Friday, 05 August 2011, 06:42 GMT
Stephen,

The enthusiasm is great...but this is really one of those "do it properly" things...
This is, after all, "the face of Rockbox".

For many players, simply wrapping "%?mv<%pvdB|.....>" around the existing volume declaration is not sufficient although it "just works".
What this really needs is:

- two conditional viewports, one for the graphical volume, on for the textual volume display. (so that the textual display can be properly aligned)
- a simple conditional statement to flip those viewports ("%?mv<%Vd(textual)|%Vd(graphical)>" for example)
and for many players of larger(ish) screen resolution...
- A larger font loaded for the textual viewport to give the volume display more "visual impact" and more closely relate to the size of the icon it is temporarily replacing.

I mentioned in IRC when this topic came up that I am happy to do the work, I just cannot do it *right now*...as soon as I get my RaaA theme into SVN I shall look into doing this, as it seems to be wanted in general and I'm more than comfortable with Rockbox skin syntax. There are many more optimizations that I wish to include in SVN cabbiev2* and while doing those, this would be simple to add.

A note about the text colour, for colour targets the foreground colour should be a mid-to-light grey (CCCCCC to be exact)...definitely not white. If colour targets do have white text in the .wps, .fms, .rwps, .rfms, lists or menus then this is something I would consider an error.


[St.]

* -Translated .wps, .fms, .rwps and .rfms "titlebars"
-Increased visual similarity between .wps, .fms, .rwps and .rfms
-"progressbar" style volume and battery indicator icons as opposed to bitmap strips
-Some tweaks to the displayed metadata (TBD) to provide as much info as possible in cases of missing metadata with conditional placement to eliminate gaps caused by empty fields (taken from my current RaaA cabbiev2 project))
Comment by Bertrik Sikken (bertrik) - Sunday, 07 August 2011, 17:11 GMT
Attached images show the volume in yellow (F6CD35) to match the other icons and in gray (CCCCCC) for comparison.

Loading...