Rockbox

Tasklist

FS#12233 - iPod 6G/Classic: LCD not displaying rockbox correctly if using emCORE >= r746

Attached to Project: Rockbox
Opened by Vencislav Atanasov (user890104) - Monday, 15 August 2011, 12:19 GMT
Last edited by Michael Sparmann (TheSeven) - Sunday, 06 November 2011, 11:35 GMT
Task Type Patches
Category LCD
Status Closed
Assigned To Michael Sparmann (TheSeven)
Operating System All players
Severity Low
Priority Normal
Reported Version Release 3.9
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

r746 of emCORE (which is the only bootloader available for Classics at the moment) introduces a change that breaks compatibility with Rockbox. In order to be compatible, Rockbox needs to ensure that a certain value of the LCD registers is set before attempting to send commands to the LCD. This is what this patch is about.
Michael Sparmann (TheSeven) takes all the credit for this patch, since he pointed me to the fix and actually added it to emCORE. I just applied it to the Rockbox's code.
Tested only on one ipod so far, please test and comment.
This task depends upon

Closed by  Michael Sparmann (TheSeven)
Sunday, 06 November 2011, 11:35 GMT
Reason for closing:  Fixed
Additional comments about closing:  Fixed in r30908
Comment by Jose Lencioni (bcoco85) - Thursday, 18 August 2011, 14:43 GMT
I can confirm this patch works with my ipodclassic.
Im using emcore r763 with rockbox r30307M (thanks to user890104).

peace!
Comment by Keren Shimshi (JollyGood) - Friday, 19 August 2011, 12:24 GMT
I also tried the patch with r30307 and emcore r763 and it's working good on my classic 3g
Comment by Hayden Pearce (St.) - Sunday, 21 August 2011, 03:01 GMT
You seem to be seriously mistaken...

r746 is *NOT* "the only bootloader available":

Quote from the builds page:
"These builds are for developers only. They may contain broken features and/or serious bugs. Don't install them if you are not a developer!"

it is not an official release...if you use it, expect problems.
If you want something well tested, use r708, which is a *Official Release* (get it here: http://www.freemyipod.org/wiki/EmCORE_Releases ) not a daily/commit based built binary that sees little extended testing other than "Yep, it boots".

Additionally, emCORE and Rockbox, while tied together, are not a sole entity...if you have problems with emCORE, bring it up with the Freemyipod project.
You can reach them at #freemyipod-support on Freenode IRC.


[St.]
Comment by Vencislav Atanasov (user890104) - Sunday, 21 August 2011, 10:10 GMT
I meant that emCORE is "the only bootloader availablle" for iPod Classic, not that the specific revision is - sorry for the misunderstanding.

I am well aware that these builds are not meant to be used by the end users, but some people disregard the warning, install them and run into issues. And this patch would decrease the support requests from people who installed incompatible versions.

The problem is actually at Rockbox's side, since Rockbox relies on the fact that a certain LCD register is set to a specific value, which is not the case in the recent emCORE versions, because emCORE implements another format (rgb666) for sending data to the LCD, which Rockbox obviously don't support (yet).

Loading...