Rockbox

Tasklist

FS#12241 - Voice menus stop working after return to menu from recording screen

Attached to Project: Rockbox
Opened by Michael Sevakis (MikeS) - Monday, 22 August 2011, 18:35 GMT
Last edited by Thomas Martitz (kugel.) - Wednesday, 26 October 2011, 18:32 GMT
Task Type Bugs
Category User Interface
Status Closed
Assigned To No-one
Operating System SW-codec
Severity High
Priority High
Reported Version Release 3.9
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

As the title suggests, voice menus cease to operate after using the recording screen. A reboot is required to restore voice menu functionality. I checked using r30339 on Gigabeat S and Sansa Fuze v2 thus suspect any SWCODEC target with recording would be affected. I do not at this point know which commit introduced the issue or if further voice issues exist.
This task depends upon

Closed by  Thomas Martitz (kugel.)
Wednesday, 26 October 2011, 18:32 GMT
Reason for closing:  Fixed
Additional comments about closing:  r30840
Comment by Michael Sevakis (MikeS) - Tuesday, 23 August 2011, 23:22 GMT
Occasionally, it seems voice stops working altogether.
Comment by Michael Sevakis (MikeS) - Thursday, 25 August 2011, 00:08 GMT
Bwahahaha! I had english-us selected as the language instead of english, which was preventing voice working at all. However, the problem reported in this task is still valid.
Comment by Michael Sevakis (MikeS) - Thursday, 01 September 2011, 10:44 GMT
This seems to possibly affect anything calling talk_disable() to temporarily disable voice that grabs the audio buffer and actually uses it. The same happens with mpegplayer and rockdoom as with recording. Plugins that simply use plugin_get_audio_buffer to stop audio along with talk_disable to disable voice appear not to affect anything.
Comment by Steve Bavin (pondlife) - Friday, 02 September 2011, 08:04 GMT
Is talk_disable even needed any more or was it required merely due to some shared resource? It was (effectively) introduced in r10789, but I don't understand the comment " /* recording_menu gets messed up: so reset talk_menu */" .
Comment by Michael Sevakis (MikeS) - Friday, 02 September 2011, 10:53 GMT
It is still needed at this point to keep voice from using stolen buffer space that isn't valid to use.
Comment by Steve Bavin (pondlife) - Friday, 02 September 2011, 13:03 GMT
Ah, I'd assumed the buflib mods had sorted that one out...
Comment by Michael Sevakis (MikeS) - Friday, 02 September 2011, 14:05 GMT
Things in that area haven't yet been converted everywhere they could be.
Comment by Thomas Martitz (kugel.) - Wednesday, 26 October 2011, 11:34 GMT
I could reproduce on the sim after adding the pcm_rec_init() call to the sim's main(). Will have a look later, but my suspicion is that voice isn't properly re-initialized after a audio_get_buffer() call.

Loading...