Rockbox

Tasklist

FS#12265 - Sansa Clip+ cannot display cabbiev2 wps at r30478

Attached to Project: Rockbox
Opened by Akio Idehara (idak) - Thursday, 08 September 2011, 14:16 GMT
Last edited by Thomas Martitz (kugel.) - Friday, 09 September 2011, 13:33 GMT
Task Type Bugs
Category User Interface
Status Closed
Assigned To No-one
Operating System Sansa AMSv2
Severity Low
Priority Normal
Reported Version Daily build (which?)
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Sansa Clip+ cannot display cabbiev2 wps at r30478 with simulator and real.

Simulator outputs is the following.
-=-=-=-=-
Not enough skin buffer: need -65386 more.
Not enough skin buffer: need -65310 more.
Not enough skin buffer: need -65313 more.
Not enough skin buffer: need -65312 more.
SDL_WaitEvent() error
SDL_WaitEvent() error
SDL_WaitEvent() error
SDL_WaitEvent() error
-=-=-=-=-
This task depends upon

Closed by  Thomas Martitz (kugel.)
Friday, 09 September 2011, 13:33 GMT
Reason for closing:  Fixed
Additional comments about closing:  r30486
Comment by Jonathan Gordon (jdgordon) - Thursday, 08 September 2011, 14:49 GMT
wierd, I'm looking into it but its nearly 1am here so use an older build I think.
Comment by Andree Buschmann (Buschel) - Thursday, 08 September 2011, 18:16 GMT
For me my own WPS (attached) does not load since r30478, cabbiev2 works fine. This is with a simulator of iPod nano 2G. The output of the simulator says: <Unable to load font 3: '13-arialbd.fnt'>
Comment by Andree Buschmann (Buschel) - Thursday, 08 September 2011, 18:26 GMT
Attached patch fixes the issue for me.
Comment by Thomas Martitz (kugel.) - Thursday, 08 September 2011, 21:59 GMT
I think I figured the problem, I described my suspicion here: http://www.rockbox.org/irc/log-20110908#22:37:49
I'll hopefully be able to provide a fix tomorrow.

Buschel, your problem is a different one.
Comment by Jonathan Gordon (jdgordon) - Friday, 09 September 2011, 00:31 GMT
Buschel: your issue is different. fonts are still loaded into the skin buffer so it means you actualy have run out of space (which is why your patch fixes it). I don't like that #define because the needed buf size doesnt have much to do with the screen size anymore. I'm hoping to look into moveing fonts across which will fix that, but in the mean time I'd prefer a fix which adds some number*SKIN_FONT_SIZE to the SKIN_BUFFER_SIZE define instead.
Comment by Andree Buschmann (Buschel) - Friday, 09 September 2011, 05:48 GMT
I'm fine with any other proper solution. I will keep my workaround until a fix has made it to svn.
Comment by Thomas Martitz (kugel.) - Friday, 09 September 2011, 11:05 GMT
My suspicion was indeed the cause. The attached patch should fix it.

Loading...