Rockbox

Tasklist

FS#12280 - Error reading ID3 tag of MP3 file with cover

Attached to Project: Rockbox
Opened by PurlingNayuki (yzflcyq) - Thursday, 15 September 2011, 11:23 GMT
Last edited by Andree Buschmann (Buschel) - Saturday, 17 September 2011, 16:38 GMT
Task Type Bugs
Category Database
Status Closed
Assigned To No-one
Operating System All players
Severity Low
Priority Normal
Reported Version Daily build (which?)
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Once I embeded a cover into some of my mp3 files and remove it, Rockbox can scan ID3 tag from it. However, I can use Foobar2000 to read tags.
The tag is written in ID3 v2.3.

And finally I'm sorry to say that I'm in China and not able to use Dropbox or Mediafire.
I uploaded the file here: http://115.com/file/dnhbrztj#
03.鳥の詩.7z
This task depends upon

Closed by  Andree Buschmann (Buschel)
Saturday, 17 September 2011, 16:38 GMT
Reason for closing:  Not a Bug
Comment by Andree Buschmann (Buschel) - Thursday, 15 September 2011, 19:26 GMT
I was not able to access the file from there.

Edit: Alternatively you could just cut off the first -- let's say -- 200 KB of the file and attach it here.
Comment by PurlingNayuki (yzflcyq) - Saturday, 17 September 2011, 06:10 GMT
OK, I split it into several files.
Please Help me upload.

First 4 part here.
Comment by PurlingNayuki (yzflcyq) - Saturday, 17 September 2011, 06:14 GMT
And the rest of the files.
Comment by Magnus Holmgren (learman) - Saturday, 17 September 2011, 08:46 GMT
It seems to work fine here, at least playing the track in the simulator (not that I can tell if it actually shows the right characters, but the title at least looks similar to the filename above). It even looks better in Rockbox than in Foobar2000 (1.1.7), where the title doesn't show up properly.

Could you explain the problem in some more detail, please? Also, which version of Rockbox are you using?
Comment by Andree Buschmann (Buschel) - Saturday, 17 September 2011, 09:28 GMT
Generally seems to work for me as well when selecting a font that supports the character set (for the test I selected 16-GNU-Unifont.fnt). Can you tell us if the displayed Title and Composer is correct?
Comment by PurlingNayuki (yzflcyq) - Saturday, 17 September 2011, 15:27 GMT
The title and ablum is correct, but can't display artist. Instead it displays the foldername.
I updated to custom r30563 and it seems to work correctly now.

Loading...