Rockbox

Tasklist

FS#12303 - iPod Video USB broken since r30546

Attached to Project: Rockbox
Opened by Andree Buschmann (Buschel) - Friday, 30 September 2011, 20:02 GMT
Last edited by Andree Buschmann (Buschel) - Monday, 03 October 2011, 06:15 GMT
Task Type Bugs
Category Operating System/Drivers
Status Closed
Assigned To No-one
Operating System iPod 5G
Severity High
Priority Normal
Reported Version Release 3.9
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Since r30546 my iPod Video does not connect via USB when running rockbox. The emergency diskmode works fine, r30545 works as well.
This task depends upon

Closed by  Andree Buschmann (Buschel)
Monday, 03 October 2011, 06:15 GMT
Reason for closing:  Accepted
Additional comments about closing:  r30701
Comment by Andree Buschmann (Buschel) - Friday, 30 September 2011, 20:32 GMT
Rolling back r30546 and r30549 against current svn (r30622) solves the problem.
Comment by Michael Sevakis (MikeS) - Saturday, 01 October 2011, 07:37 GMT
I tried all my PortalPlayer 502x targets. sa9200 wouldn't boot so I couldn't check but other than that the other three would connect just fine.

So, I wonder what's up there with video.
Comment by Andree Buschmann (Buschel) - Saturday, 01 October 2011, 07:44 GMT
Can I give any more details which might help to understand the cause?

Some detail I did not mention so far: If I connect USB rockbox switches to the USB-screen. So, rockbox recognizes the USB-connect. But there is no USB-connection established, there is no new drive available under windows.
Comment by Michael Sevakis (MikeS) - Saturday, 01 October 2011, 07:52 GMT
Does this do anything to fix the issue?

Edit: reading your comment that showed up while making the patch, I'm guessing "no".
Comment by Michael Sevakis (MikeS) - Saturday, 01 October 2011, 08:05 GMT
Hmmm...details. Is it just the computer/OS or something? I feel like there's some silly oversight.
Comment by Andree Buschmann (Buschel) - Saturday, 01 October 2011, 08:05 GMT
Your patch doesn't fix it.

Some more details: OS is Windows7.
Comment by Michael Sevakis (MikeS) - Saturday, 01 October 2011, 08:07 GMT
Oh, and is it just the iPod Video or any other iPod too?
Comment by Andree Buschmann (Buschel) - Saturday, 01 October 2011, 08:11 GMT
My iPod nano 2G works fine at r30586.
Comment by Michael Sevakis (MikeS) - Saturday, 01 October 2011, 08:35 GMT
Maybe this one! Tries a static buffer instead of using the audio buffer.
Comment by Andree Buschmann (Buschel) - Saturday, 01 October 2011, 08:38 GMT
No effect.
Comment by Michael Sevakis (MikeS) - Saturday, 01 October 2011, 09:05 GMT
ok, gotta think. so far, video is the only one confirmed to be affected as such.
Comment by Bertrik Sikken (bertrik) - Saturday, 01 October 2011, 10:44 GMT
I can check on the ipod nano 1g (PP based) as soon as I get back home again (tomorrow)
Comment by Andree Buschmann (Buschel) - Saturday, 01 October 2011, 13:22 GMT
This patch fixes the issue. I am not sure about impacts though...
Comment by Andree Buschmann (Buschel) - Saturday, 01 October 2011, 13:31 GMT
Condensed patch.
Comment by Michael Sevakis (MikeS) - Saturday, 01 October 2011, 19:39 GMT
@Andree: the v04 patch with one line also works by itself, without the reversion of v03 (which I don't think we want since we know it's not a reliable host detection method)?
Comment by Andree Buschmann (Buschel) - Saturday, 01 October 2011, 20:11 GMT
v04 works as stand-alone patch. v03 was just the first quick shot, I could reduce it to the single one line in v04.

Loading...