Rockbox

Tasklist

FS#12356 - next track advances when skip in repeat one mode

Attached to Project: Rockbox
Opened by Marcin Bukat (MarcinBukat) - Friday, 28 October 2011, 06:52 GMT
Last edited by Michael Sevakis (MikeS) - Saturday, 29 October 2011, 20:43 GMT
Task Type Bugs
Category Music playback
Status Closed
Assigned To No-one
Operating System All players
Severity Low
Priority Normal
Reported Version Release 3.9
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Way to reproduce:
1) select file from file browser
2) change repeat to 'one'
3) skip doesn't change the file (that is expected) but next track displayed in WPS advances
This task depends upon

Closed by  Michael Sevakis (MikeS)
Saturday, 29 October 2011, 20:43 GMT
Reason for closing:  Accepted
Additional comments about closing:  Patch commed in r30857
Comment by Thomas Martitz (kugel.) - Friday, 28 October 2011, 07:05 GMT
For me (on RaaA), skip does change the file. Then the WPS plays track 2, and shows track 3 as next track. Skipping again goes back to the selected file (track 1).
Comment by Michael Sevakis (MikeS) - Friday, 28 October 2011, 13:23 GMT
I'm not personally observing this yet but I can only see playback getting different files if in fact the playlist give the playback engine another path. Repeat One should result in the engine seeing the same path over and over again in an endless loop.
Comment by Michael Sevakis (MikeS) - Friday, 28 October 2011, 13:25 GMT
One possibility comes to mind, that if this happens only going from "none" to "one" then a proper flush and reload of the playlist isn't happening in some cases.
Comment by Thomas Martitz (kugel.) - Friday, 28 October 2011, 13:32 GMT
My case is when going from none to one
Comment by Thomas Martitz (kugel.) - Saturday, 29 October 2011, 15:33 GMT
I can see wodz' behavior when going from repeat all to one.
Comment by Michael Sevakis (MikeS) - Saturday, 29 October 2011, 18:27 GMT
From which screen is repeat mode being changed? I see the quickscreen calls audio_flush_and_reload_tracks. Perhaps that call is missing elsewhere.
Comment by Michael Sevakis (MikeS) - Saturday, 29 October 2011, 19:12 GMT
I tried from the playback menu and of course it didn't have the needed call. These complex settings should be done through a single call that handles the change properly as is done with cuesheets and crossfade.

So, here's a patch that takes care of that. Enlighten me of more places repeat_mode gets changed that I might have missed.
Comment by Thomas Martitz (kugel.) - Saturday, 29 October 2011, 19:16 GMT
You can change settings in skins with some tag. I don't know where/how it's implemented, though.
Comment by Michael Sevakis (MikeS) - Saturday, 29 October 2011, 19:21 GMT
Ah, thanks. It turns out that one has the needed call.
Comment by Thomas Martitz (kugel.) - Saturday, 29 October 2011, 19:31 GMT
Repeat mode touchregion seems also fine
Comment by Michael Sevakis (MikeS) - Saturday, 29 October 2011, 19:50 GMT
Ought I commit this? I saw the reported behavior without it and it did the trick to resync playback in the menu case.
Comment by Thomas Martitz (kugel.) - Saturday, 29 October 2011, 20:27 GMT
Looks good to me

Loading...