Rockbox

Tasklist

FS#12374 - r30932 may bring back font issues related to FS#12306 & FS#12336.

Attached to Project: Rockbox
Opened by zhkailing (zhkailing) - Tuesday, 08 November 2011, 14:05 GMT
Last edited by Fred Bauer (freddyb) - Thursday, 10 November 2011, 14:08 GMT
Task Type Bugs
Category Themes
Status Closed
Assigned To No-one
Operating System All players
Severity Low
Priority Normal
Reported Version Daily build (which?)
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

The modifications in font.h & font.c reintroduce font issues.
It may be related to  FS#12306  &  FS#12336 .
This task depends upon

Closed by  Fred Bauer (freddyb)
Thursday, 10 November 2011, 14:08 GMT
Reason for closing:  Fixed
Additional comments about closing:  Fixed in r30932. Hopefully, that's the last reference to FONT_UI, which is now deprecated.
Comment by Thomas Martitz (kugel.) - Tuesday, 08 November 2011, 14:18 GMT
Can you please be more specific? What change exactly?
Comment by zhkailing (zhkailing) - Tuesday, 08 November 2011, 14:23 GMT
Is it necessary to upgrade some plugins such as lrcplayer for the disuse of FONT_UI ?
Comment by zhkailing (zhkailing) - Tuesday, 08 November 2011, 14:27 GMT
I means that the bugs in  FS#12306  and  FS#12336  are reproduced now.
Comment by Fred Bauer (freddyb) - Tuesday, 08 November 2011, 23:17 GMT
It looks like lrcplayer wasn't updated. I couldn't reproduce the keyboard problem.
Comment by Jonathan Gordon (jdgordon) - Tuesday, 08 November 2011, 23:25 GMT
Thanks Fred, I'll commit this tonight if you don't get to it first
Comment by Fred Bauer (freddyb) - Tuesday, 08 November 2011, 23:41 GMT
That's fine.
Comment by Fred Bauer (freddyb) - Thursday, 10 November 2011, 02:54 GMT
zhkailing, do you still have any issues after r30932?
Comment by zhkailing (zhkailing) - Thursday, 10 November 2011, 06:31 GMT
lrcplayer is OK,thanks.
But It would seem that the latest rockbox doesn't support some 32-bit Bmps(Can be read, but not displayed properly). If I convert it to 24-bit, the theme returns to normal.
Comment by Thomas Martitz (kugel.) - Thursday, 10 November 2011, 09:07 GMT
What program did you create that file with?

Bitmap contains alpha information (all zeros, though). Zero is considered entirely transparent as of recently that's why it's not displayed. Re-saving the file in gimp makes that zeros all 255s (0xff) which is entirely opaque and displayed correctly.

So not displaying it is correct considering our definition of transparency in 32bit bitmaps. Considering that, though, it's curious why there's slight garbage at the edges.
Comment by Thomas Martitz (kugel.) - Thursday, 10 November 2011, 09:10 GMT
Gimp displays the image correctly though. Unless you exchange a single 0x00 with 0xff, then it displays it transparent. So it seems to detect the all-zeros magic for non-transparency.
Comment by Fred Bauer (freddyb) - Thursday, 10 November 2011, 12:55 GMT
I'm going to close this unless there are other font issues.
Comment by zhkailing (zhkailing) - Thursday, 10 November 2011, 13:26 GMT
OK .

Loading...