Rockbox

Tasklist

FS#12384 - AMSv1 bootloader USB mode does not attach since r30548

Attached to Project: Rockbox
Opened by Michael Chicoine (mc2739) - Saturday, 12 November 2011, 01:05 GMT
Last edited by Rafaël Carré (funman) - Wednesday, 14 December 2011, 05:07 GMT
Task Type Bugs
Category Bootloader
Status Closed
Assigned To No-one
Operating System Sansa AMSv1
Severity Low
Priority Normal
Reported Version Daily build (which?)
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

In bootloader builds starting with r30548, the bootloader USB mode does not work. This was tested with an e200v2 on win7 and ubuntu.

The last working build is r30546 and r30547 does not build due to build errors.
This task depends upon

Closed by  Rafaël Carré (funman)
Wednesday, 14 December 2011, 05:07 GMT
Reason for closing:  Fixed
Additional comments about closing:  r31241
Comment by Michael Chicoine (mc2739) - Monday, 21 November 2011, 02:21 GMT
It looks like this is caused by a missing #define HAVE_BOOTLOADER_USB_MODE in firmware/export/config/sansae200v2.h (the other amsv1 devices also need this).

Unfortunately, adding the define makes the bootloader too large to be patched by mkamsboot, even when using thumb mode and -Os. (see FS#12380)

Removing show_logo will drop the bootloader file size and does not cause any noticeable problem, since the bootloader logo was displayed for such a brief time. Verbose mode is still available to display bootloader info.

Loading...