Rockbox

Tasklist

FS#12442 - [Fuze+] Flac undefined instruction when going from mp3 to flac

Attached to Project: Rockbox
Opened by Jean-Louis Biasini (JeanLouisBiasini) - Saturday, 10 December 2011, 19:36 GMT
Last edited by Jean-Louis Biasini (JeanLouisBiasini) - Monday, 27 August 2012, 13:12 GMT
Task Type Bugs
Category Music playback
Status Closed
Assigned To No-one
Operating System Sansa Fuze+
Severity Low
Priority Normal
Reported Version Release 3.9
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

This is probably related to the sansa fuze+ port rather than to the codec...
I'm reported this one separatly from  FS#12429  for it is very easy to reproduce on the device.
It occurs everytime the player has to goes from reading mp3 file to reading flac file. This does not involve generating dynamic playlist for even skipping from file A to B inside a predefined playlist will cause it. The reverse isn't true: from flac to mp3 doesn't crash the player.

Undefined instruction at 63E5C2A0
backtrace start
pc: 0x63E5C2A0
sp: 0x00005390
backtrace end

jean-louis@debian:~/Bureau/rockbox-devtree/rockbox/buidl$ ../utils/analysis/find_addr.pl 0x63E5C2A0 1
This address is in codec space, please select the codec which was used with this address:
[1]: ay.elf
[2]: a52_rm.elf
...
[35]: flac.elf
....

Selection: 35
/home/jean-louis/Bureau/rockbox-devtree/rockbox/buidl/apps/codecs/flac.elf -> decoded0


This task depends upon

Closed by  Jean-Louis Biasini (JeanLouisBiasini)
Monday, 27 August 2012, 13:12 GMT
Reason for closing:  Works For Me
Additional comments about closing:  by 08/27/2012 the bug cannot be reproduce anymore. Solving probably related to 4908b8e where pamaury fixed some dma issue
Comment by Jean-Louis Biasini (JeanLouisBiasini) - Saturday, 10 December 2011, 19:54 GMT
another undefined:
Undefined instruction at 63E712E0
backtrace start
pc: 0x63E712E0
sp: 0x00005280
backtrace end

Alternatively we also get data abort:
Data abort at 6006BB10
FSR 0x8
(domain 0, fault 8)
address 0x65E85284
backtrace start
pc: 0x6006BB10
sp: 0x60000118
backtrace end

or:

Data abort at 6006BB10
FSR 0x8
(domain 0, fault 8)
address 0x63E74578
backtrace start
pc: 0x63E74578
sp: 0x00005280
backtrace end
(Those 2 data abort were get with flac 5.1 (so mainly another bigger kind of flac)


this address 0x00005280 seems to appears quite often (I get other value for "at X" but sp: 0x00005280 or 0x00005390)
Comment by Jean-Louis Biasini (JeanLouisBiasini) - Sunday, 11 December 2011, 16:35 GMT
Buschel has made some test on another device and confirms this should be fuze+ related
Comment by Jean-Louis Biasini (JeanLouisBiasini) - Sunday, 11 December 2011, 18:15 GMT
another one:
Undefined instruction at 63E832E0
backtrace start
pc: 0x63E832E0
sp: 0x00005280
backtrace end
Comment by Andrej (rarog) - Tuesday, 20 December 2011, 01:00 GMT
I can reproduce 63E832E0 crash... According to find_addr.pl this points to _plugin_end_addr in flac.elf

Loading...