Rockbox

Tasklist

FS#12447 - [FUZE+]File of different format (flac, mpc, ogg, aac) being skipped.

Attached to Project: Rockbox
Opened by Jean-Louis Biasini (JeanLouisBiasini) - Sunday, 11 December 2011, 18:04 GMT
Last edited by Jean-Louis Biasini (JeanLouisBiasini) - Monday, 27 August 2012, 13:57 GMT
Task Type Bugs
Category Music playback
Status Closed
Assigned To No-one
Operating System Sansa Fuze+
Severity Low
Priority Normal
Reported Version Release 3.9
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

1. Way to reproduce:
The bug appears randomly but always stay a while once appeared. It cannot be reproduced systemically. But always appears at the end. It has been reported by three different fuze+'s user so far.

2. Description
The files won't be played but skipped until the playlist reach its end.

3. Workaround
- Desactiving directory cache (settings > system > Disk) always get rid of it. Reactiving bring the bug back.
- Reinitialize the database (wether there is no DB or an already present up-to-date one). But the player will then be back on non-playing behaviour after reboot.
This task depends upon

Closed by  Jean-Louis Biasini (JeanLouisBiasini)
Monday, 27 August 2012, 13:57 GMT
Reason for closing:  Works For Me
Additional comments about closing:  I didn't experience this bug for a while. There's been some correction on caching and fuze+'s dma and storage driver has been recently. I guess this must have been solved somehow. Please reopen it if you're still having this issue
Comment by Jean-Louis Biasini (JeanLouisBiasini) - Sunday, 11 December 2011, 18:06 GMT
tested also WMA and MP3 files seems unaffected
Comment by MichaelGiacomelli (saratoga) - Sunday, 11 December 2011, 23:35 GMT
Does disabling the database also work around the problem?
Comment by Jean-Louis Biasini (JeanLouisBiasini) - Monday, 12 December 2011, 08:52 GMT
Even if there is no database builded (i.e. fresh installation and selecting file with file browser) the problem can occurs. But also with an up-to-date database. This bug doesn't seems to be database related (i.e. with or without db it can occurs). However the action of initializing database interact with it, and take the bug temporaly (i.e. until reboot) out. (yeah this is weird...)
Comment by Dave Hooper (stripwax) - Wednesday, 11 January 2012, 16:00 GMT
I suspect initializing the database causes bug FS#12216 and hence deactivates dircache ... which is why initializing the database seems to 'fix'  FS#12447  temporarily...
Comment by Jean-Louis Biasini (JeanLouisBiasini) - Wednesday, 11 January 2012, 16:27 GMT
as stated in the workaround the bug occurs also with no database at all (i.e. database not being initialized) or does the initialization could cause a but that even erasing all the DB file & rebooting could not solve?
Comment by Jon Lido (lido) - Thursday, 10 May 2012, 20:08 GMT
I can confirm that this bug still exists on my Fuze+ with revision 645680d (2012-05-10) with AAC LC files encoded with iTunes 10.3.1, QuickTime 7.6.6. This bug was reported in the Fuze+ development forum thread by halonachos117 on 2011-12-04.

With my Fuze+ it is easy to repeat the bug- play an album of AAC files with either the database or file browser. The WPS quickly skips through all tracks in the dynamic playlist instead of playing them. AAC files fail consistently, while MP3 files consistently play without issue. If during the skipping process you can hit the pause button before the end of the playlist is reached, wait briefly, and unpause playback AAC files will begin to play. Tapping pause/play too quickly without a brief pause (less than a second) will resume the skipping behavior instead of fixing AAC playback. Once in "working mode", AAC files will continue to play until playback stops.

Here's the interesting part- AAC files will always play as part of a playlist that begins with MP3 files.

I suspect this indicates a problem with the process of loading or initializing the AAC codec.

Loading...