Rockbox

Tasklist

FS#12451 - Some metadata characters are not being displayed properly

Attached to Project: Rockbox
Opened by Terry Layton (Terry The Great) - Tuesday, 13 December 2011, 23:36 GMT
Last edited by Dominik Riebeling (bluebrother) - Tuesday, 03 January 2012, 21:59 GMT
Task Type Bugs
Category ID3 / meta data
Status Closed
Assigned To No-one
Operating System All players
Severity Low
Priority Normal
Reported Version Release 3.9
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Player: Sansa Fuze v2
Original manufacturer's firmware version: 02.03.33
Rockbox version: 3.10 (current version)

The characters ‘ (left single quote), ’ (right single quote or apostrophe), “ (left double quote), ” (right double quote) and : (colon) from the metadata (song title, artist, album title) of any MP3 (ID3v2.3) are displayed as a box outlined in dots on the WPS screen display. This occurs with all of the fonts and when any theme is being used. The original Sansa® Fuze™ firmware does not have this problem.

For visual proof of this complaint, view the website: www.terrythegreat.wordpress.com
(At 9.47 Megabytes, it was too big for your file attachment limits)
This task depends upon

Closed by  Dominik Riebeling (bluebrother)
Tuesday, 03 January 2012, 21:59 GMT
Reason for closing:  Not a Bug
Additional comments about closing:  No response from the reporter.

Also, the tone in the report is pretty inappropriate. Unless the reporter is willing to help with this (likely a problem related to the files' metadata) issue there's no point in keeping this open.

And for completeness: Foo(R) Bar TM.
Comment by MichaelGiacomelli (saratoga) - Wednesday, 14 December 2011, 01:01 GMT
Post a link to the file.
Comment by Dominik Riebeling (bluebrother) - Wednesday, 14 December 2011, 16:25 GMT
Have you selected the correct codepage?
Comment by Boris Gjenero (dreamlayers) - Wednesday, 14 December 2011, 16:48 GMT
This works for me with ID3 version 2.3 and 2.4 tags written by EasyTAG 2.1.6. What tagging program are you using?
Comment by Dominik Riebeling (bluebrother) - Wednesday, 14 December 2011, 21:18 GMT
According to Wikipedia ID3v2.4 is the first version that allows storing data as UTF-8. Since you claim your tags to be v2.3 the data has to use either UTF-16 (which I doubt, since Windows usually uses local encodings) or ISO8859-1 encoding. ISO8859-1 doesn't contain the characters you're complaining about, cp1252 does. This looks pretty much like Windows storing the tags as cp1252 (which is *similar* to ISO8859-1 but not identical), the Sandisk firmware following Windows' wrongly used encoding and Rockbox using the encoding that is specified.

As has been said, without the file it's impossible to analyze this.

Loading...