Rockbox

Tasklist

FS#12472 - Permanent time settings menu

Attached to Project: Rockbox
Opened by Nick Peskett (nickp) - Wednesday, 21 December 2011, 11:42 GMT
Last edited by Nick Peskett (nickp) - Thursday, 22 December 2011, 07:19 GMT
Task Type Patches
Category User Interface
Status Closed
Assigned To No-one
Operating System All players
Severity Low
Priority Normal
Reported Version Release 3.9
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

The current Settings > Time & Date menu contains items that can operate without a RTC.

The problem is that this menu only exists when the device has a RTC, otherwise the remaining items (currently sleep timer related) are shifted into the root settings menu.

This patch creates a new permanent Time Settings menu which holds these and other time related items. The existing Time & Date menu becomes a sub menu of it (on RTC targets), with most of it's items stripped out.
This task depends upon

Closed by  Nick Peskett (nickp)
Thursday, 22 December 2011, 07:19 GMT
Reason for closing:  Rejected
Additional comments about closing:  Not much interest in this menu layout
Comment by Nick Peskett (nickp) - Wednesday, 21 December 2011, 11:44 GMT
The patch is currently pretty raw, I'll work on updating it and the manual if there's interest.
Comment by Jonathan Gordon (jdgordon) - Wednesday, 21 December 2011, 13:22 GMT
I don't tihnk this patch is a good idea. The 3 settings left on non-rtc targets (2x sleep timer, 1x idle poweroff) have absolutely nothing to do with "time settings" and would become unobvious and possibly lost there. Admittedly t&d arn't right for these also.

Of course, we could do this but have the lang string different on non-rtc targets, but doesn't that negate much of the point of the patch? (and call it what? startup/shutdown options?)
Comment by Nick Peskett (nickp) - Wednesday, 21 December 2011, 13:36 GMT
I agree.

The real point of the patch is a permanent home for non RTC settings.

Unfortunately fixing this invariably grinds to a halt due to the finer points of semantics.

Loading...