Rockbox

Tasklist

FS#12473 - Rename "mp3entry.embed_cuesheet" to "mp3entry.embedded_cuesheet" and pull out a field

Attached to Project: Rockbox
Opened by Alexander Levin (fml2) - Wednesday, 21 December 2011, 18:23 GMT
Last edited by Alexander Levin (fml2) - Thursday, 22 December 2011, 19:00 GMT
Task Type Patches
Category ID3 / meta data
Status Closed
Assigned To No-one
Operating System All players
Severity Low
Priority Normal
Reported Version Release 3.9
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

This patch renames "mp3entry.embed_cuesheet" to "mp3entry.embedded_cuesheet". It also pulls the field "present" out of the "embedded_cuesheet" structure and renames it to "has_embedded_cuesheet".

This patch, together with  FS#12470 , unify how cuesheet and albumart data are represented in mp3entry.
This task depends upon

Closed by  Alexander Levin (fml2)
Thursday, 22 December 2011, 19:00 GMT
Reason for closing:  Accepted
Additional comments about closing:  Committed as r31406
Comment by Boris Gjenero (dreamlayers) - Wednesday, 21 December 2011, 18:40 GMT
I like your renames. They make things more obvious and easier to understand.

To me, pulling the field out only makes sense if there's interest in shrinking mp3entry. It's possible to remove unused parts, at a cost of added code complexity and size. It's also possible to replace bools with single bit flags.
Comment by Alexander Levin (fml2) - Wednesday, 21 December 2011, 19:19 GMT
I pulled out the field not becase of memory reduction, but in the first line because I find it a better style and because it brings albumart and cuesheet in line.

Loading...