Rockbox

Tasklist

FS#12481 - MP3 (128kbit cbr) distorted after 4-5min playing time on Sansa Clip Plus

Attached to Project: Rockbox
Opened by Thomas P. (mnemonix) - Sunday, 25 December 2011, 00:02 GMT
Last edited by MichaelGiacomelli (saratoga) - Sunday, 04 November 2012, 17:41 GMT
Task Type Bugs
Category Codecs
Status Closed
Assigned To No-one
Operating System All players
Severity Low
Priority Normal
Reported Version Release 3.10
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

I got a brand new Sansa Clip + with preinstalled firmware 1.02.15.

I tried to install Rockbox via automatic installer and firmware 1.02.16 and Rockbox 3.10 stable. First everything worked fine.

On the second look the were some quite strange things.

One of these strange things is, that there is always a data abort when trying to select "credits" in the info menu. Ok, I don't need the info menu, but It's certainly not indended to crash the player when selecting this.

Worse is that after 4-5 min my mp3 (common 128kbit constant bitrate mp3) begins to be distorted. I also experienced that a part of the mp3 was skipped and the player continued directly on the next track. When rewinding back and hearing the part again, it's fine again for further 4min or so ...

I think this is not intended, so I opened a bug report ...

I also tried manually installation with 3.19.1 and the behaviour is the same.

The original firmware works fine and doesn't show any signs of distortion ...
This task depends upon

Closed by  MichaelGiacomelli (saratoga)
Sunday, 04 November 2012, 17:41 GMT
Reason for closing:  Out of Date
Comment by Thomas P. (mnemonix) - Sunday, 25 December 2011, 08:22 GMT
Attached an sample file how the distortions sound

It's randomly sometimes lots stronger but it is always distorted after a couple of minutes. I also had it once that it pumped really annoying about every second or something liked this ... Hard to explain

Unfortunately I can't attache the original file here because it has 5MB ... And it is copyrighted ...
Comment by MichaelGiacomelli (saratoga) - Thursday, 12 January 2012, 21:25 GMT
Can you reproduce this with one of the official mp3 test tracks: http://download.rockbox.org/test_files/

If not, post a link to the file that causes the problem.

Loading...