Rockbox

Tasklist

FS#12484 - [Fuze+] Shuffle doesn't works when playing tracks from "Files"

Attached to Project: Rockbox
Opened by Mathieu A (kumy) - Sunday, 25 December 2011, 20:20 GMT
Last edited by Nils Wallménius (nls) - Wednesday, 28 December 2011, 10:41 GMT
Task Type Bugs
Category Configuration
Status Closed
Assigned To No-one
Operating System Sansa Fuze+
Severity Low
Priority Normal
Reported Version Daily build (which?)
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

1. Way to reproduce:
Activate shuffle in settings -> Playback settings -> Shuffle -> Yes
Then go to "Files", then any dir and play the first song.
Fast forward near track end. wait for the end.

2. Bug description
Shuffle option seems to be activated in the settings, but icon in currently playing file is not "activated". At the end of a file, it pass directly to the next file.

3. No bug if:
no workaround found

4. test performed:
verify the shuffle option is correctly set in the settings -> yes
tried activate / desactivate.

notes:
it has not been tested within a playlist.
RB r31429-111225
This task depends upon

Closed by  Nils Wallménius (nls)
Wednesday, 28 December 2011, 10:41 GMT
Reason for closing:  Invalid
Additional comments about closing:  Just a misunderstanding of the ui it seems
Comment by MichaelGiacomelli (saratoga) - Sunday, 25 December 2011, 20:34 GMT
I just tried on the Clip+ and shuffle works as expected. The expectation should be that the tracks play in non-alphabetical order. What order are you seeing?
Comment by Mathieu A (kumy) - Sunday, 25 December 2011, 20:58 GMT
>What order are you seeing?
My tracks are alphabetical ordered.

I expect them to be played in random order.

Does your "shuffle icon" is activated when you play songs ?
Comment by Jean-Louis Biasini (JeanLouisBiasini) - Sunday, 25 December 2011, 21:25 GMT
Following your way to reproduce exactly on Fuze+. I could not reproduced it. Are you sure you set the shuffle mode correctly?
Comment by Mathieu A (kumy) - Sunday, 25 December 2011, 21:33 GMT
>Are you sure you set the shuffle mode correctly?
yes, quite sure... but I'll give it another try...
Comment by Mathieu A (kumy) - Sunday, 25 December 2011, 21:45 GMT
hum.. sorry files are effectively randomly played !
I was misunderstanding the UI. I expect the track number to jump randomly, but in fact, numbers displays sequentially, and tracks ARE played randomly.

But the icon does not activate.
Is it really this icon (see attached file) that represent "random" ?
Comment by Jean-Louis Biasini (JeanLouisBiasini) - Sunday, 25 December 2011, 21:56 GMT
> Is it really this icon (see attached file) that represent "random" ?
I guess so but this is all dependant on the theme used. I will ask someone to close this bug then

Loading...