Rockbox

Tasklist

FS#12517 - "Disk full" message, but there IS free space on disc

Attached to Project: Rockbox
Opened by Alexander Levin (fml2) - Sunday, 08 January 2012, 16:55 GMT
Last edited by Thomas Martitz (kugel.) - Thursday, 19 January 2012, 08:03 GMT
Task Type Bugs
Category Recording
Status Closed
Assigned To No-one
Operating System Sansa e200
Severity Low
Priority Normal
Reported Version Release 3.10
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

This happens on my Sansa e280v1 with r31634-120108

I wanted to record something using the inbuilt microphone. The menu "RB Info" tells me there is space on the internal card:

132MB/7.45GB

When I start the recording, and then stop it while the WRS screen shows about 50KB, I get the message "Disk is full. Press PREV to continue."

After that, there is no recorded file. (The file should be created in the root directory of the internal card; WRS shows "Filename: /./R_MIC...")

But there IS space on the card! I could copy a file (via USB) of size 100 KB without problems.

So I think something is fishy in the recording code.

Is this somehow related to  FS#7721 ?
This task depends upon

Closed by  Thomas Martitz (kugel.)
Thursday, 19 January 2012, 08:03 GMT
Reason for closing:  Fixed
Additional comments about closing:  6e11289
Comment by Thomas Martitz (kugel.) - Sunday, 08 January 2012, 17:44 GMT
IIRC it depends on the chosen encoder and rockbox is making sure there's enough space for XX seconds.
Comment by Alexander Levin (fml2) - Sunday, 08 January 2012, 17:48 GMT
This happens with both MP3 and WAV encoder.
Comment by Boris Gjenero (dreamlayers) - Sunday, 08 January 2012, 17:59 GMT
This is probably  FS#12500 
Comment by Alexander Levin (fml2) - Sunday, 08 January 2012, 18:18 GMT
Yes, I can confirm that if I set the recording directory to something else than the default ("/") the recorded file is created. It's a pity I didn't know that before and so missed a very interesting moment! :-/
Comment by jasontaylor (jasontaylor) - Saturday, 14 January 2012, 20:16 GMT
echo "rec path: /" >> d:\.rockbox\config.cfg
fixes the problem.

Not so fast Alexander. There is no default in config.cfg. And the default isn't "/". It is "/./," which indeed has no available space, since it isn't a valid directory.

Cheers,
Jason Taylor
http://twitter.com/jasontaylor7
Comment by Alexander Levin (fml2) - Saturday, 14 January 2012, 20:21 GMT
I admit, that with the default being "/" was a speculation of me.

Loading...