Rockbox

Tasklist

FS#12585 - Bar tags no longer work

Attached to Project: Rockbox
Opened by Toby Davies (Digivate) - Saturday, 11 February 2012, 20:06 GMT
Last edited by Jonathan Gordon (jdgordon) - Tuesday, 14 February 2012, 08:54 GMT
Task Type Bugs
Category Themes
Status Closed
Assigned To Jonathan Gordon (jdgordon)
Operating System All players
Severity High
Priority High
Reported Version Release 3.10
Due in Version Next release
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

WPS bar tags (such as %pb and %pv) which include parameters other than x, y, width, height and image no longer work.
This task depends upon

Closed by  Jonathan Gordon (jdgordon)
Tuesday, 14 February 2012, 08:54 GMT
Reason for closing:  Fixed
Additional comments about closing:  in 9acd70288dfa47cac084b965a046df6f71d4ee26
Comment by Jonathan Gordon (jdgordon) - Saturday, 11 February 2012, 22:35 GMT
i need much more information than this.
Comment by Toby Davies (Digivate) - Sunday, 12 February 2012, 13:00 GMT
Sorry for being too vague.

I've noticed this issue regarding themes for the Sansa Clip Zip, but I think it could be more universal than effecting just one player as it's a problem with bar tag syntax.

Bar tags (http://www.rockbox.org/wiki/CustomWPS#Bar_Tags) such as the progress bar or volume level no longer work if you add any of these following options:

horizontal
vertical
invert
slider
image
backdrop
nofill
nobar

So while something really simple like this works ...

# Preload images
%xl(v,volume.bmp,0,0)

# Volume
%V(0,85,96,11,-)
%pv(0,0,96,11,v)

... adding another option, such as backdrop, doesn't work ...

# Preload images
%xl(v,volume.bmp,0,0)
%xl(r,ruler.bmp,0,0)

# Volume
%V(0,85,96,11,-)
%pv(0,0,96,11,v,backdrop,r)

I've got three themes that were working last week ago but not anymore, and it's not a problem that's just related to my themes. I've noticed that several themes that were created by other people and listed for the Clip Zip last week have been removed. Having checked through them (copies which I'd previously downloaded to my PC) the common elements in them is that they all have additional bar tag options.

I've attached one of my theme cfg files, containing some offending bar tag code, but the problem is not related to just this one theme.
   Blu.sbs (0.9 KiB)
Comment by Jonathan Gordon (jdgordon) - Tuesday, 14 February 2012, 03:46 GMT
http://git.rockbox.org/?p=rockbox.git;a=commit;h=40ecdf6811d9a717ef67ff1833a67dbb521f91be is probably the cause... I thought I tested the parser changes but apparently not well enough.

Loading...