Rockbox

Tasklist

FS#12645 - Olympus Mr-100: No sound with 3.11.2

Attached to Project: Rockbox
Opened by Josh (jmosis) - Friday, 13 April 2012, 01:52 GMT
Last edited by Dominik Riebeling (bluebrother) - Sunday, 23 September 2012, 19:49 GMT
Task Type Bugs
Category Music playback
Status Closed
Assigned To No-one
Operating System PortalPlayer-based
Severity Low
Priority Normal
Reported Version Release 3.11
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

I am new to this, so i am not sure if 3.11.2 should be 100% functional, but I have no sound when playing tracks and the up/down scrolling appears very sensitive, making it difficult to make a menu selection.
This task depends upon

Closed by  Dominik Riebeling (bluebrother)
Sunday, 23 September 2012, 19:49 GMT
Reason for closing:  Fixed
Additional comments about closing:  Fixed in master. See comments.
Comment by Frank Gevaerts (fg) - Friday, 13 April 2012, 09:19 GMT
The sound could be related to FS#9628. Did you boot with the headphones plugged in? If not, could you try that?

I'll try to reproduce this tonight.

Comment by Frank Gevaerts (fg) - Friday, 13 April 2012, 20:07 GMT
OK, this is not the same as FS#9628. Sound does indeed not work at all (while 3.10 does work)
Comment by Dominik Riebeling (bluebrother) - Friday, 13 April 2012, 20:30 GMT
I've changed the task summary to be more descriptive -- the original summary wasn't at all, and there are people that get email notifications about tasks so a descriptive summary is important. Next time please try to be more descriptive -- it's more important what doesn't work than what player exactly is affected (the affected player is also important but that's more for the task details). Thanks.
Comment by Frank Gevaerts (fg) - Friday, 13 April 2012, 20:59 GMT
This started with r30991 / 9e07ef2b. Unfortunately that doesn't make any sense to me, that commit doesn't even get near any files that could cause this.
Comment by Bertrik Sikken (bertrik) - Tuesday, 17 April 2012, 20:49 GMT
I played a bit with the simulator because I also noticed a non-functional WPS (current track title is missing).
This particular problem started at 34031cba5bddcc29dee0f61b3ea6ee1529014181
Comment by Frank Gevaerts (fg) - Tuesday, 22 May 2012, 12:42 GMT
This seems to be solved in master since da6cebb6b0b17b4a75a2bd4f51b7cf70b5dafe40. It's basically impossible to backport the fix to the stable branch.

We've removed the m:robe100 from the stable release for now, it will be back in 3.12.

If you own an m:robe 100 and you have already upgraded to 3.11, I recommend upgrading to a development build. If you're still on 3.10, stay there for now.

Loading...