Rockbox

Tasklist

FS#12653 - Rockbox randomly crashes during playback

Attached to Project: Rockbox
Opened by Bruno Gil (brgil96) - Tuesday, 24 April 2012, 21:39 GMT
Task Type Bugs
Category Music playback
Status Unconfirmed
Assigned To No-one
Operating System Sansa AMSv2
Severity Low
Priority Normal
Reported Version Daily build (which?)
Due in Version Undecided
Due Date Undecided
Percent Complete 0%
Votes 0
Private No

Details

So, I have a Clip Zip at the moment. Been using rockbox on it since day 1, and since day one i've always had an issue: during playback, when accessing files from the SD card, the player randomly freezes. It's not always, it's not when accessing the same files or some specific characteristic shared by them, it just appears to be random. When it freezes, the LCD usually still responds to my commands (i can access menus, see the file info, even change song and it will display in the playback screen), but the actual playback doesn't, and I eventually have to hard reset it. I guess it's some kind of SD compatibility issues: I have an 8GB class 4 PNY. I know it's not the own card's problem since it worked perfectly on my Clip+ and does on my Android Cellphone.
I've been updating daily builds for this device at least once a week since I got it, and it happens with every build.
This task depends upon

Comment by MichaelGiacomelli (saratoga) - Wednesday, 25 April 2012, 00:12 GMT
The same SD card driver is used on the Clip+ as the Clip Zip (they're basically the same player with a different screen). So if the SD card works in one but not the other, I tend to think its not the driver. Are you certain only files on the SD card crash?
Comment by Bruno Gil (brgil96) - Wednesday, 25 April 2012, 19:10 GMT
Yes I am, since day one that I've been monitoring it and it's always SD card files. Also, forgot to mention, if i remove the sd card when the player hangs, it goes back to normal.
Comment by John Romero (sssUSER) - Sunday, 29 April 2012, 00:26 GMT
I have a similar problem with the V2 Fuze (Sansa AMSv2) :
http://www.rockbox.org/tracker/task/12658
Comment by Matt Russell (english_bob) - Thursday, 29 August 2013, 14:53 GMT
I have a similar problem with my Zip. Playback stops abruptly and won't resume. UI still responds- will navigate menus etc, but won't play music. Only happens when accessing files stored on the MicroSD card, which worked fine in my old Clip+, and doesn't happen using the OG firmware. Using the current stable RB v3.13.

Weirdly, changing the theme it seems to have resolved the problem. Was having regular crashes (several times a day) with the DKFT_Minimum_Zip_INV theme, but no problems so far using the nkorth_minimalist theme. Maybe that helps...
Comment by Matt Russell (english_bob) - Monday, 02 September 2013, 10:03 GMT
Update: scratch that about changing theme. Still hangs. Can confirm that removing the SD card causes the player to return to the main menu screen and resume normal service.

Loading...