Rockbox

Tasklist

FS#12748 - Cannot create talk files with Rockbox Utility 1.3.0

Attached to Project: Rockbox
Opened by Neil Popham (rabid) - Wednesday, 05 September 2012, 12:59 GMT
Last edited by Dominik Riebeling (bluebrother) - Wednesday, 05 September 2012, 20:52 GMT
Task Type Bugs
Category Utils
Status Closed
Assigned To No-one
Operating System Another
Severity Low
Priority Normal
Reported Version Release 3.10
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Rockbox Utility:

Installed 1.3.0 and can no longer create talk files on my Sansa Clip+.

Downloaded 1.2.14 and that still works.

All checkboxes checked, SAPI TTS test works fine.
This task depends upon

Closed by  Dominik Riebeling (bluebrother)
Wednesday, 05 September 2012, 20:52 GMT
Reason for closing:  Fixed
Comment by Dominik Riebeling (bluebrother) - Wednesday, 05 September 2012, 14:44 GMT
Please post the output of the System Trace dialog after the problem occured.
Comment by Neil Popham (rabid) - Wednesday, 05 September 2012, 15:00 GMT
Logs for both 1.3.0 (not working) and 1.2.14 (working) attached.
Comment by Dominik Riebeling (bluebrother) - Wednesday, 05 September 2012, 17:50 GMT
Ok, this actually is a problem -- it is caused by the path being constructed wrong. Interestingly it seems to work in some cases (haven't figured which ones exactly), it did also work when I tested the new selection UI. I guess this calls for a standalone generator (something I want to have since quite a while anyway ...)
Comment by Dominik Riebeling (bluebrother) - Wednesday, 05 September 2012, 19:44 GMT
Can you please confirm this issue to be resolved with the current development version available at http://tinyurl.com/rbutil-dev/RockboxUtility-05caadb.zip ?
Comment by Neil Popham (rabid) - Wednesday, 05 September 2012, 20:06 GMT
Have not tested .talk file, but it has been created. Trace attached in case it is any use.

Many thanks for your swift work.

Cheers!
Comment by Dominik Riebeling (bluebrother) - Wednesday, 05 September 2012, 20:51 GMT
The generation itself didn't change so I would be really surprised if the generated talk file didn't work. Thanks for the quick confirmation.

Loading...