Rockbox

Tasklist

FS#12797 - RadioArt dataaborts with a corrupted skin buffer

Attached to Project: Rockbox
Opened by Jonathan Gordon (jdgordon) - Thursday, 03 January 2013, 12:07 GMT
Last edited by Thomas Martitz (kugel.) - Monday, 23 December 2013, 11:24 GMT
Task Type Bugs
Category Battery/Charging
Status Closed
Assigned To No-one
Operating System All players
Severity High
Priority Normal
Reported Version Release 3.12
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Using a fms with radioart causes the DAP to data abort.

this feature has been disabled in the code so it doesnt crash.

To reproduce:

add %Cl() and %Cd to your fms..

-----------------
%wd
%Cl(60,36,100,100,c,c)
%Cd
---------------------


git bisect suggest da6cebb6b0b17b4a75a2bd4f51b7cf70b5dafe40 broke it.

Setup a presets list and have at least one radio art image which will be found. Then switch the preset, the first time an image is loaded the skin buffer will be corrupt.

There is a separate bug where the image is not loaded on the preset the radio starts in, so you may have to switch left and right if the first preset has the image.
This task depends upon

Closed by  Thomas Martitz (kugel.)
Monday, 23 December 2013, 11:24 GMT
Reason for closing:  Fixed
Additional comments about closing:  22e802e
Comment by Thomas Martitz (kugel.) - Thursday, 03 January 2013, 13:07 GMT
Is FS#12771 possibly related?
Comment by Thomas Martitz (kugel.) - Thursday, 03 January 2013, 13:08 GMT
Comment by Jonathan Gordon (jdgordon) - Thursday, 03 January 2013, 13:11 GMT
quite possibly. the timeing in 12771 sounds correct, 12404 seems too old (but may still be valid, probably unrelated though)
Comment by Terry Layton (Terry The Great) - Wednesday, 16 January 2013, 22:27 GMT
Finally! I have been trying for months to get some attention paid to this bug (I submitted 12771)!

Radio Art worked just fine (as it had for ages) at the beginning of May 2012 but by mid-summer of 2012 it did not. There was a change in one of the daily builds and this was carried over into the present official release version (3.12). Now my themes for the Sansa Fuze v2 and the Sansa Fuze+ have a big blank area on the FMS screen. I can no longer show my friends that Rockbox has such spectacular and advanced features because I have had to disable the Radio Art option pending a bug fix. How embarrassing for myself and Rockbox!

If Radio Art should become functional again, please inform us users when this occurs.
Comment by Michael Sevakis (MikeS) - Thursday, 16 May 2013, 19:02 GMT
The use of the buffers through buflib is not stable. I do have code that implements a shared memory manager but (huge badonkadonk BUT), callbacks thwart sound threading synchronization (ostrich algorthm isn't acceptable).
Comment by Thomas Martitz (kugel.) - Friday, 17 May 2013, 05:37 GMT
I'm quite sure buflib isn't buggy. But probably the calling code is.
Comment by Michael Sevakis (MikeS) - Friday, 17 May 2013, 16:05 GMT
Of course it isn't buggy but it does introduce things that aren't pleasant to deal with and handling of the big leftover shared area isn't correct to allow the one using that area to deal with shrinking it.
Comment by Thomas Martitz (kugel.) - Wednesday, 22 May 2013, 19:18 GMT
I have uploaded http://gerrit.rockbox.org/r/#/c/477/ after examining the radio art code a bit. Can it possibly fix this problem?
Comment by Thomas Martitz (kugel.) - Sunday, 09 June 2013, 15:48 GMT
Actually, after examining even more, http://gerrit.rockbox.org/r/#/c/483/ fixes this problem for real.

Loading...