Rockbox

Tasklist

FS#12806 - Checkwps fails, but skin works on sim/target

Attached to Project: Rockbox
Opened by Hayden Pearce (St.) - Monday, 21 January 2013, 00:34 GMT
Last edited by Jonathan Gordon (jdgordon) - Tuesday, 22 January 2013, 20:44 GMT
Task Type Bugs
Category User Interface
Status Closed
Assigned To No-one
Operating System All players
Severity Low
Priority Normal
Reported Version Daily build (which?)
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

The parser is barfing on syntactically correct statements, for example:

Checking /home/saint/Desktop/iLike Classic/Current/iLike Classic/wps/iLike.wps...
WPS parsing failure
Error on line 67.
%?bp<%?bc<%t(1.0)%xd(Ea);%t(1.0)%xd(Eb)|%xd(Ec)>|%bl(1,1,21,10,image,B,backdrop,
^ 'Expected argument separator' Here
saint@saint-desktop:~/Development/Rockbox/development/rockbox/build$

"%?bp<%?bc<|>|>" parses correctly.

"%?bp<%?bc<%t(1.0)%xd(Ea);%t(1.0)%xd(Eb)|%xd(Ec)>|%bl(1,1,21,10,image,B,backdrop,C)>" is rejected by checkwps and isn't displayed by either the sim or device.

"%?bp<%?bc<%t(1.0)%xd(Aa);%t(1.0)%xd(Ab)|%xd(Ac)>|%?bl<%xd(Ad)|%xd(Ad)|%xd(Ae)|%xd(Af)|%xd(Ag)|%xd(Ah)|%xd(Ai)|%xd(Aj)|%xd(Ak)|%xd(Al)|%xd(Am)|%xd(An)|%xd(Ao)|%xd(Ap)|%xd(Aq)|%xd(Ar)|%xd(As)|%xd(At)|%xd(Au)|%xd(Av)|%xd(Aw)|%xd(Ax)|%xd(Ay)|%xd(Az)>>" is rejected by checkwps but is displayed correctly in the sim and on device.


[Saint]
This task depends upon

Closed by  Jonathan Gordon (jdgordon)
Tuesday, 22 January 2013, 20:44 GMT
Reason for closing:  Not a Bug
Additional comments about closing:  problem user not checkwps
Comment by Hayden Pearce (St.) - Monday, 21 January 2013, 00:45 GMT
full theme .zip attatched:
Comment by Hayden Pearce (St.) - Monday, 21 January 2013, 00:50 GMT
A .zip of the same theme before changing the syntax around showing syntax that works in the sim and on device but fails checkwps:
Comment by Michael Sevakis (MikeS) - Tuesday, 22 January 2013, 16:05 GMT
Jd, why the removal of critical technical terminology from the title?
Comment by Jonathan Gordon (jdgordon) - Tuesday, 22 January 2013, 20:44 GMT
:)

Loading...