Rockbox

Tasklist

FS#12811 - Problem with %Cl tag

Attached to Project: Rockbox
Opened by Sahand (Sahand_N) - Friday, 25 January 2013, 10:53 GMT
Last edited by Jonathan Gordon (jdgordon) - Monday, 04 February 2013, 08:35 GMT
Task Type Bugs
Category Themes
Status Closed
Assigned To No-one
Operating System Another
Severity Low
Priority Normal
Reported Version Daily build (which?)
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

I'm using a Sansa Clip Zip,
Starting from build 9b7edbf (2013-01-16), Rockbox completely ignores maxwidth and maxheight specified within %Cl tag.
The attached screenshots are from 9b7edbf and d24c220 (2013-01-15) using exactly the same theme.
And the tag I used is: %Cl(0,0,96,96,c,c).
This task depends upon

Closed by  Jonathan Gordon (jdgordon)
Monday, 04 February 2013, 08:35 GMT
Reason for closing:  Not a Bug
Comment by Sahand (Sahand_N) - Friday, 25 January 2013, 10:54 GMT
oops!
Comment by Jonathan Gordon (jdgordon) - Sunday, 03 February 2013, 02:18 GMT
I need to see the whole wps to understand the issue... is 96x96 bigger or smaller than the viewport it is in?
Comment by Jonathan Gordon (jdgordon) - Sunday, 03 February 2013, 02:38 GMT
talking in IRC, it seems like the current behaviour is actually correct and the old behaviour was wrong. http://www.rockbox.org/irc/log-20130203#03:17:14
Comment by Sahand (Sahand_N) - Monday, 04 February 2013, 08:28 GMT
You're right, I forgot to mention it. This is the viewport:
%Vl(a,0,10,96,74,-)
%Cl(0,0,96,96,c,c)
%Cd
Starting from build 9b7edbf, Rockbox loads the AA 74px high and 74px wide because of the dimension specified within %Vl (or %V), rendering maxwidth and maxheight of the %Cl tag completely useless.
It also changes the way some themes like http://themes.rockbox.org/index.php?themeid=1524&target=sansaclipzip look.
I know it's silly to display AA on such a small screen and I don't want to that, but some themes on bigger players might be affected.
Comment by Jonathan Gordon (jdgordon) - Monday, 04 February 2013, 08:35 GMT
ok, so yeah, this is actually the correct behaviour and your theme is broken :) change the viewport to be 96x96 if that is what you want.

Loading...