Rockbox

Tasklist

FS#12844 - Bar tags with "vertical" option, touch screen: controls reversed against drawing direction

Attached to Project: Rockbox
Opened by Marianne Arnold (pixelma) - Friday, 22 March 2013, 17:05 GMT
Last edited by Thomas Martitz (kugel.) - Sunday, 12 January 2014, 12:14 GMT
Task Type Bugs
Category Themes
Status Closed
Assigned To No-one
Operating System All players
Severity Low
Priority Normal
Reported Version Release 3.12
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Touch screen devices (noticed on my RaaA target).

For touch aware bar tags such as progress or volume bar (%pb, %pv) which use the "vertical" option the drawing direction is reversed compared to the slider control direction.

E.g. a volume bar is drawn bottom -> top (low -> high volume) but you have to slide down to increase volume and slide up to decrease it. Additionally setting the "invert" option both will be inverted so that the actual problem stays.
This task depends upon

Closed by  Thomas Martitz (kugel.)
Sunday, 12 January 2014, 12:14 GMT
Reason for closing:  Fixed
Additional comments about closing:  c0a02c9
Comment by Marianne Arnold (pixelma) - Saturday, 11 January 2014, 14:38 GMT
I'll attach my "test and play around" .wps which exhibits the behaviour and was made for my phone with a display resolution of 320x480. It should work with equal sized or larger screens as the only limiting factor are viewport dimensions and placement (no backdrops). I didn't take the time to clean the WPS but it should be possible to get rid of everything but the "volume bar" viewport including its content to see the effect. The zip contains the bitmaps folder and the .wps in a "wps" directory, so should be extracted to the "rockbox" folder.

While looking through the file before uploading here, I noticed something which could possibly be a lead to the cause of the bug, just an idea though: according to the part about touchscreen areas in CustomWPS there should be an option "reverse_bar" for bar tags. I tried my volume bar with and without that option and there was no visible effect, so maybe some code sets it always to true for vertical bars?

P.S.: This bug hasn't been confirmed with a very recent build (last check with 51ed6da-131022), maybe it's been fixed already though I don't remember fixes in this area. And I also hope the WPS itself is not broken because of the heavy use of conditional %Vf/%Vb and the recent development...
   wps.zip (3.1 KiB)

Loading...