Rockbox

Tasklist

FS#12848 - Signal strength tag %tr doesn't divide equally when using conditionnals

Attached to Project: Rockbox
Opened by Ludovic Jacques (lebellium) - Wednesday, 27 March 2013, 08:43 GMT
Last edited by amaury pouly (pamaury) - Saturday, 30 March 2013, 16:17 GMT
Task Type Bugs
Category Themes
Status Closed
Assigned To No-one
Operating System All players
Severity Low
Priority Normal
Reported Version Daily build (which?)
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

In all my FMS I use %?tr<%xd(Va)|%xd(Vb)|%xd(Vc)|%xd(Vd)|%xd(Ve)|%xd(Vf)> to display signal strength and I noticed Ve and Vf would never display because it is not divided equally at all. Vf would only display if you get 100% signal strength, which never happens in real life I guess while it should display from around 83% signal strength if it was divided into 6 equal parts.
This task depends upon

Closed by  amaury pouly (pamaury)
Saturday, 30 March 2013, 16:17 GMT
Reason for closing:  Not a Bug
Additional comments about closing:  ask by lebellium
Comment by Ludovic Jacques (lebellium) - Wednesday, 27 March 2013, 08:49 GMT
You can try it with this theme http://themes.rockbox.org/index.php?themeid=1787 for example.
Comment by Thomas Martitz (kugel.) - Thursday, 28 March 2013, 08:36 GMT
Is this actually a bug or by design? Can you use the penultimate element to display "almost full"?
Comment by Ludovic Jacques (lebellium) - Thursday, 28 March 2013, 23:29 GMT
Sorry for my mistake. That's actually intended behavior. It only divides from 1 to N-1 into N-1 equal parts and N=100% (full state). The task can be closed.

Loading...