Rockbox

Tasklist

FS#12873 - Album art does not parse in ID3v2 tag

Attached to Project: Rockbox
Opened by MichaelGiacomelli (saratoga) - Saturday, 15 June 2013, 20:42 GMT
Last edited by Thomas Martitz (kugel.) - Thursday, 27 June 2013, 16:58 GMT
Task Type Bugs
Category Codecs
Status Closed
Assigned To No-one
Operating System SW-codec
Severity Low
Priority Normal
Reported Version Daily build (which?)
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

http://web.mit.edu/mgg6/www/Game_Scoop_Presents__Predicting_Nintendos_2013_E3.mp3

The ID3v2 tag in this file contains a fair amount of random metadata which seems to confuse Rockbox's parser such that album art is not displayed. Extracting the album art using foobar2000, deleting the existing tag and then reattaching it fixes display of the embedded JPEG so the jpeg itself is fine.

Tested with today's build (7c7fa36) on device (e200v1) and in sim.
This task depends upon

Closed by  Thomas Martitz (kugel.)
Thursday, 27 June 2013, 16:58 GMT
Reason for closing:  Not a Bug
Additional comments about closing:  See last comment. We don't support this file
Comment by Dominik Riebeling (bluebrother) - Saturday, 15 June 2013, 20:52 GMT
This is interesting -- at least from the filename this is the same file as in  FS#12870 , which showed album art fine on e200v1 sim for me after b6ddbc4.
Comment by MichaelGiacomelli (saratoga) - Saturday, 15 June 2013, 21:02 GMT
I just recompiled the sim from current head and it definitely does not parse this file.
Comment by Dominik Riebeling (bluebrother) - Saturday, 15 June 2013, 21:04 GMT
Strange. I'll try to give it a closer look tomorrow.
Comment by Dominik Riebeling (bluebrother) - Saturday, 15 June 2013, 21:46 GMT
Ok, had a short look at the file linked. Despite the filename it is different than the problematic file in  FS#12870 . Your file has the "unsynchronization" flag set. Rockbox does not support album art if this is set (clearly stated in the metadata code, see also my comment in FS#12795). Rewriting the tag in foobar2000 to clear this flag (need to force tag to be v2.3, as otherwise foobar wouldn't rewrite it) makes its album art show up in Rockbox.

Loading...