Rockbox

Tasklist

FS#12889 - Audible pop right after setting Repeat/Shuffle

Attached to Project: Rockbox
Opened by Juan Gonzalez (Nephiel) - Tuesday, 13 August 2013, 08:28 GMT
Last edited by Michael Sevakis (MikeS) - Friday, 16 August 2013, 22:58 GMT
Task Type Bugs
Category Music playback
Status Closed
Assigned To No-one
Operating System All players
Severity Low
Priority Normal
Reported Version Daily build (which?)
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

A loud 'pop' can be heard on both left and right channels shortly after changing Repeat or Shuffle from the Quickscreen while using Meier crossfeed. The 'pop' is louder in volume than the keyclick set to "Moderate".

Oddly, this only happens when using the Quick Screen and Meier crossfeed. It doesn't happen changing Repeat/Shuffle from the shortcuts menu or the main menu. It doesn't happen with crossfeed Off or Custom crossfeed either.

This issue is always reproducible, even in the simulator.
Steps to reproduce:

1.- Enable Meier crossfeed: Settings->Sound Settings->Crossfeed->Crossfeed->Simple(Meier)
2.- Make sure you have the Quick Screen enabled: Settings->General Settings->System->Use Shortcuts Menu instead of Quick Screen->No
3.- Start playback of any song.
4.- Access the Quick Screen from the WPS.
5.- From the Quick Screen, change the setting of Repeat and/or Shuffle to any other value.
6.- Leave the Quick Screen going back to the WPS.
7.- Wait 2-3 seconds. Listen for the 'pop'.

I noticed the issue on build 49bcf35. Still present in daily build from August 6th.
This task depends upon

Closed by  Michael Sevakis (MikeS)
Friday, 16 August 2013, 22:58 GMT
Reason for closing:  Fixed
Additional comments about closing:  b1209d4
Comment by Michael Sevakis (MikeS) - Friday, 16 August 2013, 13:13 GMT
Interesting. Seems to happen when the next track metadata is updated.
Comment by Michael Sevakis (MikeS) - Friday, 16 August 2013, 13:32 GMT
Try b1209d4
Comment by Juan Gonzalez (Nephiel) - Friday, 16 August 2013, 18:47 GMT
No more 'pop's here, looks like that did the trick.

Loading...