Rockbox

Tasklist

FS#12903 - IPOD 5.5 GEN BUG WHEN USING FFT PLUGIN

Attached to Project: Rockbox
Opened by Aled (schmal) - Tuesday, 24 September 2013, 13:23 GMT
Last edited by Jonathan Gordon (jdgordon) - Monday, 25 November 2013, 23:50 GMT
Task Type Bugs
Category Plugins
Status Closed
Assigned To No-one
Operating System iPod 5G
Severity Low
Priority Normal
Reported Version Release 3.12
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

This is on release 3.13.

When using the FFT plugin, the music is regularly interupted and the FFT trace goes moemntarily blank. This appears to be worse with the lines display in logarithmic mode and happens less frequently on the full colour sonogram.
Not sure if there is a buffering issue, but it would appear to be.
This task depends upon

Closed by  Jonathan Gordon (jdgordon)
Monday, 25 November 2013, 23:50 GMT
Reason for closing:  Not a Bug
Comment by Hayden Pearce (St.) - Sunday, 29 September 2013, 11:39 GMT
No. Not a buffering issue (you should have somewhere in the vacinity of 50MB+ available to the audio buffer).

Its likely a "iPod 5G has a reasonably crap CPU" thing, and you're likely overloading it. EQ, dithering, crossfade, compressor, stereo width...everything costs.

Now, since FFT works absolutely fine for me on my 5.5G I'm going to roll with the overloaded CPU scenario. Having seen this before, my instinct tells me this may well be due to improper use of the parametric EQ. I am willing to bet that if you were to back up your config.cfg and reset the settings on the device the FFT issues will magically disappear.


[Saint]

Loading...