FS#1350 - shut off fail

Attached to Project: Rockbox
Opened by Anonymous Submitter - Tuesday, 13 May 2003, 13:27 GMT
Last edited by Linus Nielsen Feltzing (linusnielsen) - Friday, 05 November 2004, 07:11 GMT
Task Type Bugs
Category User Interface
Status Closed
Assigned To No-one
Operating System
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No


I can't shut off the divice unless it is connected to the
battery charger.
No problem when using the genuine archos firmware.
This task depends upon

Closed by  Linus Nielsen Feltzing (linusnielsen)
Friday, 05 November 2004, 07:11 GMT
Reason for closing:  Fixed
Comment by Linus Nielsen Feltzing (linusnielsen) - Tuesday, 13 May 2003, 14:25 GMT

For how long do you press the OFF key? You might have to
push it for quite a few seconds.
Comment by Anonymous Submitter - Wednesday, 14 May 2003, 15:59 GMT

I have exactly the same problem!
Archos Jukebox Recorder USB1.1 6GB
Comment by Markus Braun (steel0r) - Wednesday, 14 May 2003, 16:18 GMT

I have the same trouble.
I pressed the button for about a minute -> no success!
The button works but fine during normal operation but
shutdown is not possible.
Only chance is to take out the batteries and during startup
press the OFF button.
No problems with the Archos OS though.
Comment by Anonymous Submitter - Monday, 18 August 2003, 15:44 GMT

I have exactly the same problem
Archos Jukebox FM Recorder USB 2.0 hacked to 40GB
Comment by Linus Nielsen Feltzing (linusnielsen) - Sunday, 11 April 2004, 00:10 GMT

Does it work better with 2.2?
Comment by Primus (primussucks) - Monday, 12 April 2004, 03:49 GMT

I have the exact OPPOSITE problem. I cannot power the unit
off when it IS connected to the AC adapter. As soon as I
unplug the AC cord, I can then power off as normal.

version 2.2 from 2004-03-11
Comment by Primus (primussucks) - Monday, 12 April 2004, 03:51 GMT

Model: Archos Jukebox 6000
Comment by Reiner K. Kappenberger (reinerka) - Thursday, 20 May 2004, 14:18 GMT

Same sympton here. It used to work in all previous releases
on my Archos Juckebox 20GB. After upgrading the unit the
only way to shut it off is taking the batteries out.
Comment by James Stewart (wartstew) - Sunday, 27 June 2004, 03:16 GMT

I've had the same problem for about a year I think. I was hoping
it would go away, but it hasn't. Here might be some additional
information for you concerning my player:

Model: JB6000
Firmware: 4.53
Current Rockbox: Daily-Build 20040625

Some "Debug" info:

Batt: ~5.8
(while powered from orignal "Kings" USA issued adapter). Note,
my batteries are currently failing, giving only about 3 hours of
play time. I'm due for new ones, these are the original ones that
came with the unit several years ago!

HW info:
ROM: 4.53
USB: neg
ATA: 0x300m
Mask: 0000
Flash: ??,??
RomCRC: 222F

Here is the specific problem:

Sometime during the Rockbox development, probably about 3
months after the major cool "car adapter" mode came out, my JB
would stop turning off while external power was connected. Here
are the details:

1) When the "stop" button is pressed and held for a long time
while unit is playing, nothing happens, the unit continues to play.
A quick press of the stop button works normally and stops the play

2) If the unit is stopped, and the stop button is pressed for a long
time, it will display "Battery Charging", but then will return to the
file browsing screen as soon as the stop button is released.

3) Another anomaly that seemed to happen at the same time is
that when external power is removed, and after the idle time-out
is exhausted, the display will freeze, the backlight will stick on,
and all buttons will be non functional except the "stop"(power-off)
button, and then only while the external power is removed, until I
power cycle the machine.

And of course this works just fine with the latest Archos 'MOD' file.

If no one wants to work on this problem, can I at least get a
vintage version of Rockbox that worked with my player correctly. I
can't remember if Ver 1.4 had the Car-adapter-mode or not, I also
like the "classy" "fade mode". Probably the earliest versions
available with these features I would be happy with for the rest of
the lifetime of my player.

I even can help track this problem down a little if I knew where to
access old changelogs and matching source code for that era
where the problem started. Sorry I don't have the exact date, but
it was around the first time someone complained on
archosjukebox6000 Yahoo group that they couldn't turn their unit
off with Rockbox and external power. I think either Bjorn or Linus
responded to this complaint that the unit really never turns off
anyway when plugged into external power, so why do you wish it
to say that it did? I suspect this person was having the same
problem I and others have.

Thanks for donating otherwise great software to the general
Comment by Linus Nielsen Feltzing (linusnielsen) - Sunday, 27 June 2004, 09:16 GMT

As we repeatedly keep saying to other people with the same

1) The unit never turns off with the charger attached, not
even with the original firmware. It stays on, saying
"CHARGING", for no reason at all.

2) The unit charges just as fine without saying "CHARGING"
on the screen. Rockbox keeps running as normal, charging the
battery in the meantime.

So, there is no need to fake a shutdown.

On the other hand, the failure to power off when the idle
timeout has expired *is* a bug, and I am investigating it.
Comment by Reiner K. Kappenberger (reinerka) - Sunday, 27 June 2004, 22:59 GMT

I have tried for nearly a minute and it won't shut off. This
only happens with the charger connected. If the unit was
started without the charger connected it can be shut down as

Comment by Linus Nielsen Feltzing (linusnielsen) - Tuesday, 13 July 2004, 08:36 GMT


You can't shut off the jukebox with the charger attached.
It's a hardware limitation. Period.
Comment by Reiner K. Kappenberger (reinerka) - Tuesday, 13 July 2004, 13:31 GMT

With not shutting off, I mean it KEEPS ON PLAYING. It's not
a problem of displaying BATTERY CHARGING, which is the
normal behaviour.

As a previous post stated, it will display BATTERY CHARGING
and then jump back to the track where it left off.

Comment by Linus Nielsen Feltzing (linusnielsen) - Tuesday, 13 July 2004, 13:37 GMT

OK, so you want it to stop the music with a long press of STOP?

Comment by Primus (primussucks) - Tuesday, 13 July 2004, 14:10 GMT

Since when is it a "hardware limitation"

It worked fine in 2.1

I know it worked fine because I noticed the change when I
upgraded to the latest rockbox... just like others.

NOTE: This is for us 6000 users... other models I cannot
speak for, and may in fact be a hardware limitation for them.
But for the 6000 it is not a limitation.

Comment by Linus Nielsen Feltzing (linusnielsen) - Tuesday, 13 July 2004, 14:17 GMT

Unless you have a very old Player 6k, i very much doubt that
you ever have been able to turn the jukebox off with the
charger attached.

You might have come as far as rebooting into the "CHARGING"
state, but not shut it off.
Comment by Primus (primussucks) - Tuesday, 13 July 2004, 14:42 GMT

I'll test for you when time allows... but one thing is for sure,
what it does now is not what it used to do. I may be
using "off" and displaying the word "charging" synonomously
becasue it used to appear to be off.

Now the unit displays the directory two levels above when it
goes "off" and leaves the backlight on all night when using the
sleep feature. Whether or not it displays "charging" or the
directory name (for me it says "books") doesn't really matter I
suppose, though "charging" would make more sense.

What really bothers me is the backlight staying on all night.
This may in fact be the underlying bug. I have the feature to
have the backlight on when charger is plugged in. I think the
backlight should go off when the unit turns off/goes to
charging/or whatever we want to call it after a SLEEP event

As it is now, when I sometimes fall asleep listening to a book,
I wake up to see the backlight burning and displaying a
directory name. The unit may technically be off... but it sure
doesn't look like it is. It should look like it is off by displaying
charging with the backlight off.


Hope this is clear.
Comment by Anonymous Submitter - Tuesday, 13 July 2004, 20:41 GMT

I'm okay with the idea that the unit doesn't really shut off when
the power cable is connected, my problem is with all the side
effects that a (possibly related) program change seemed to
cause a while back. Here is a review:

1) In car adapter mode, the unit will not shut off after idle time
out is achieved after external DC power is removed, instead,
the unit seems to "hang" requiring me to remove external DC
power, then power the unit down with the "stop" button, then
restart the unit to return to a normal power-on mode.

2) Unit will no stop playing if external DC power is present and
the stop button is pressed. You have to remove external DC
power first.

3) (I don't use this one, so I'm relying on a previous post): The
backlight stays lit after the sleep timer is exhausted (I wonder if
it even quits playing, maybe it hangs like in the car adapter

Again, with some earlier version of Rockbox, all this worked
perfectly for me. I only wish I still had that earlier version.


Of course, despite this gripe, I still *really* appreciate all the
effort the Rockbox people have put into this project. It has
kept me enjoying my antiquated JB6K, even in the company of
all those newer, sleeker, (and hard to get batteries for) units
that are on the market today.
Comment by Linus Nielsen Feltzing (linusnielsen) - Wednesday, 14 July 2004, 05:22 GMT

OK, I now understand a bit more of what you mean.

1) This is a confirmed bug, and I am investigating it.

2) This works for me. I just tried playing a file with the
charger attached and I could stop it by pressing STOP. No

3) The sleep timer doesn't attempt to shut off the player
when the sleep timer has expired (since it is impossible).
However, I agree that it should turn off the backlight.
Comment by Linus Nielsen Feltzing (linusnielsen) - Wednesday, 14 July 2004, 10:09 GMT

I have now fixed issue #1.
Comment by James Stewart (wartstew) - Thursday, 15 July 2004, 01:25 GMT

Yes I tried out a bleeding edge build:

The Car-Adapter-Mode works perfectly again - Thanks.

You can now stop a song from playing by pushing the stop
button again when the power is plugged in - Thanks again.

A little tweaking with the sleep mode, and I think you'll have it.

For me, my JB6K is near perfect once again.

Comment by Linus Nielsen Feltzing (linusnielsen) - Thursday, 15 July 2004, 05:27 GMT

We now shut off the backlight when the sleep timer expires.
Please try the next bleeding edge or daily build.
Comment by Linus Nielsen Feltzing (linusnielsen) - Tuesday, 05 October 2004, 12:02 GMT

No response, I assume ot works OK now.