FS#1485 - FM Recorder 20 shuts off on playback

Attached to Project: Rockbox
Opened by Marc Reiter (broncomarc) - Tuesday, 01 July 2003, 03:12 GMT
Last edited by Linus Nielsen Feltzing (linusnielsen) - Monday, 01 November 2004, 10:32 GMT
Task Type Bugs
Category Music playback
Status Closed
Assigned To No-one
Operating System
Severity Low
Priority Normal
Reported Version Release 2.0
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No


I have a brand new FM Recorder 20 which I bought
because RockBox sounds so cool. Label says Ver 20GB,
P/N 300131 Bootup says OS Ver 1.30j, Rockbox says
the ROM is version 1.23. (I know.. that menu says keep
out :-)

It seems to work fine under the Archos OS, but it will
not play MP3s under the RockBox OS. (FM Recorder
version 2.0) Every time it tries to play an MP3, it locks
up for 14 seconds, then powers off.

It did work for 2 or 3 songs when I first put Rockbox on,
but I can not repeat it. I even took Rockbox off and
reloaded it, and it still powers off.

I can boot up under Rockbox, then switch over to
Archos OS and it plays just fine.

Everything I've tried in Rockbox works great except for
playback. All it does is shut off.

- Marc
This task depends upon

Closed by  Linus Nielsen Feltzing (linusnielsen)
Monday, 01 November 2004, 10:32 GMT
Reason for closing:  Fixed
Comment by Linus Nielsen Feltzing (linusnielsen) - Friday, 04 July 2003, 07:50 GMT

Really weird. On my FM recorder it works just fine. Does the
same thing happen if you run the latest daily build?
Comment by Marc Reiter (broncomarc) - Friday, 04 July 2003, 17:48 GMT

Yes.. I just tried today's build (7/4) and it does the same

Comment by Linus Nielsen Feltzing (linusnielsen) - Saturday, 13 March 2004, 21:56 GMT

Does it work with the 2.2 release?
Comment by Marc Reiter (broncomarc) - Monday, 29 March 2004, 23:14 GMT


I tried 2.2 and I thought it was working at first then it
started shutting off again.. I FINALLY figured out the
condition that makes it shut off!!!

It shuts off on anything I ripped from my own CDs, but it will
play anything that I download. I used FreeRip using Lame
encoder to rip my CDs. Here's the info WinAmp gives about
one of my rips:

Size: 3531962 bytes
Header found at: 497 bytes
Length: 220 seconds
MPEG 1.0 layer 3
128kbit, 8469 frames
44100Hz Stereo
CRCs: No
Copyrighted: No
Original: Yes
Emphasis: None

Any Ideas??

- Marc
Comment by Linus Nielsen Feltzing (linusnielsen) - Tuesday, 30 March 2004, 06:43 GMT

Can you attach one of these tracks to this bug report? Or
send it to me: linus at haxx dot se. Thanks.
Comment by Linus Nielsen Feltzing (linusnielsen) - Tuesday, 30 March 2004, 14:17 GMT

OK, I have analyzed the track you've sent me, and the ID3
tag is really screwed up. The ID3 frames have the flags set
totally wrong, and our ID3 parser crashes because of it.

Still, the crash wasn't supposed to happen, and I found and
fized a few bugs in the ID3 parser while debugging your problem.

Rockbox doesn't crash anymore on your file, but you should
really consider fixing your tags, because they are not
following the specifications.
Comment by Anonymous Submitter - Saturday, 03 July 2004, 19:36 GMT

That's rather consistent with what Linus is saying, Obviously
FreeRip is creating the files in a manner that Rockbox is
sensitive to. It may not be just a tag issue.
Easy to reproduce so I assume it should be easy to fix.